6

I can't seem to change the language over an NX session.

I am using Ubuntu 12.04 and locally I just use Alt+Shift to alter language. When I connect to a remote server using NX , I can not use this key combination to alter the language I type at the far end.

I am sure the nxserver is working - used to use it for a long time. I changed my local OS though (was running Mint 12, and now I'm running ubuntu 12.04). So I had to reinstall Nomachine's NX, and now it is not working.

Any clues?

  • I tried Shift-Caps and Shift-Space but that doesn't work.
  • Try with Shift + CapsLock. – Radu Rădeanu Jun 10 '13 at 14:46
  • @RaduRădeanu nope, that doesn't work. – nass Jun 10 '13 at 16:24
  • Try Alt+SpaceBar. – Mitch Jun 11 '13 at 9:02
  • @Mitch, that does not work either. Does it work for you? Is this even the key combination you use to change languages locally? This is not a key combination issue. when I press Alt+Shift I still get to language indication to switch locally. It is just that on the far end, this switching does not occur. I still type in english remotely...! – nass Jun 11 '13 at 9:28
0

follow me... go to system settings then click on keyboard layout click on '+' and select your language the click on options go to "keys to change layout" then mark 'Alt+Shift'

0

You say the language indication changes locally, so the actual Alt+Shift shortcut doesn't even get there. You could change one side's shortcut so that they don't conflict anymore (I don't think anything, other than virtual machines and Microsoft remote desktop products -- which I can't see fit -- could completely hook up the keyboard)

If you could hook the keyboard input of the program and made it get the input of the X server itself, then yes, that's a more complicated way of alleviating the conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.