0

Was using Ubuntu 12.10 (on a ThinkPad T430i), things started jumping and freezing so I shut down.

When I try to boot up, it always fails. Trying to boot in recovery mode, I get errors such as "I/O error (dev sda)", "mounting /dev on /root/dev failed: no such file/directory." I ran a diagnostic to check for sector errors and there were a lot (e.g. sector error 5936256; however I did not tell my Lenovo machine to try and fix the errors). I can be more specific if you tell me what to post, but the amount of errors I'm getting is vast.

Windows 7 will not boot either.

I'm guessing there's something fatally wrong with the hard-drive. So my primary question is: how can I back-up my data before I try any fixes? There are numerous files I had not yet backed up. My secondary question is: what steps should I take to try and diagnose and fix this problem?

Thank you enormously in advance.

UPDATE: I booted up with Ubuntu Live CD. I couldn't get fdisk to run, but when I tried to mount 232 GB File System I get the following error:

Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sda5, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

When I run disk utility on my hard disk, I get: Current Pending Sector Count, Normalized 59, Worst 59, Threshold 0, and Value 1160 Sectors. Screenshot of SMART Data is here: http://www.foopics.com/show/01f6dc2a4e47915367be5300b57500f1

So that looks bad...Do I have any option besides making a clone of the File System?

  • Be sure to mount the disk in read-only mode if you do mount it. Try using sudo fdisk -l from a Ubuntu live dvd/usb and see if it is valid. – daboross Jun 10 '13 at 5:34
  • When booting from a Live CD, how do I ensure that no disks are automatically mounted/ensure that they are mounted in read-only mode? – Bill Jun 10 '13 at 5:55
  • the live CD won't mount anything besides SWAP, and that should harm it. Don't use nautilus to mount drives. Just boot up and run sudo fdisk -l. It should tell you if the partition table is still valid. Edit your question with the output. – daboross Jun 10 '13 at 6:05
  • I am in the process of doing that. But to be clear: you meant that mounting SWAP shouldn't harm it, right? – Bill Jun 10 '13 at 6:21
  • Yes, sorry. It shouldn't harm it. If your partition table is valid and there is SWAP on your hard disk, it will mount and use that. Though because none of your files are stored in SWAP and the SWAP is a contained area on your hard disk, it shouldn't affect the other partitions. Thank you for correcting me there. – daboross Jun 10 '13 at 6:24
0

Try to boot something like http://www.ultimatebootcd.com/ from external device such as CD or usb stick. There is GSmartControl which you can use to check for the hard disk health and tools to clone the hard disk

  • Thank you. I will run and grab a CD so I can follow your advice. How would you suggest I go about cloning my disk? (Also, is there any method for backing-up only particular files, as opposed to the entire disk?) – Bill Jun 10 '13 at 5:18
  • I suppose you could try to boot something like damn small linux from CD and mount the disk to read the files in it. – TMKCodes Jun 10 '13 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.