I have sony vaio SVE151117F, ubuntu 12.10.I used to see brightness animation upon pressing Fn+F6,F5 but not actual brightness of screen. I have tried to implement as said in http://ubuntuforums.org/showthread.php?t=2086359 but now I cant even see the brightness level animation.There is no change in brightness level of screen as usual.

I tried below links too , but still problem persists. unable to change brightness settings in sony vaio e series laptop http://vaioubuntu.wordpress.com/2008/12/04/finally-a-brightness-how-to-for-vaio-fw-series/

  • Have a look at this Post. – Mitch Jun 9 '13 at 11:59

Go to the link below and download the driver by entering the commands posted their. Check the list of supported cards (probably listed their if not don't get panic give it a try. Personally mine is not their but that commands worked for me)


After installing reboot your laptop. then try this:

  1. Create the file /usr/share/X11/xorg.conf.d/15-nvidia.conf:

    gksu gedit /usr/share/X11/xorg.conf.d/15-nvidia.conf
  2. Copy/paste the following content:

     Section "Device"
      Identifier              "Device0"
      Driver                  "nvidia"
      VendorName              "NVIDIA Corporation"
      Option "RegistryDwords" "EnableBrightnessControl=1"
  3. Save the file and reboot


dont mess that directory usr share i messed there and count open get and gui so i had to go in safe mode then remove that usr/share/x11/xx-vendor.conf

then do these.


note: if you havent installed nvidia driver. Install it before you continue this.

in terminal

# nvidia-xconfig

this creates /etc/X11/xorg.conf . edit it.

# sudo su  // become root
# gedit /etc/X11/xorg.conf 

find Section "device" in text. it shold look like it on the rightside

from this                        TO   this     
Section "Device"                  | Section "Device"
 Identifier "Device0"             |   Identifier  "Device0"
 Driver     "nvidia"              |   Driver      "nvidia"
 VendorName "NVIDIA Corporation"  |   VendorName  "NVIDIA Corporation"
                                  |   Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection                        | EndSection

save changes (ctrl+S).
log out. log in.

we are done!! now Fn + Up,Down is adjusting the brightness.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.