In lubuntu-rc.xml Lubuntu doesn't have a hotkey to maximize the current window.


Here are some keybindings I use for window control on Lubuntu/LXDE. The first binding is what you're searching for but I thought you might find the other ones useful as well:

<!-- Keybindings for window tiling -->

    <keybind key="C-W-Up">        # FullScreen
      <action name="Maximize"/>
    <keybind key="C-W-Down">        # MiddleScreen
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>center</x><y>center</y><width>50%</width><height>50%</height></action>

    <keybind key="C-W-Left">        # HalfLeftScreen
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>0</x><y>0</y><height>100%</height><width>50%</width></action>
    <keybind key="C-W-Right">        # HalfRightScreen
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>-0</x><y>0</y><height>100%</height><width>50%</width></action>

    <keybind key="C-W-1">        # UpperQuarterLeft
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>0</x><y>0</y><height>50%</height><width>50%</width></action>

    <keybind key="C-W-2">        # LowerQuarterLeft
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>0</x><y>-0</y><height>50%</height><width>50%</width></action>

    <keybind key="C-W-3">        # LowerQuarterRight
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>-0</x><y>-0</y><height>50%</height><width>50%</width></action>

    <keybind key="C-W-4">        # UpperQuarterRight
      <action name="UnmaximizeFull"/>
      <action name="MoveResizeTo"><x>-0</x><y>0</y><height>50%</height><width>50%</width></action>

You might have to tweak the percentages based on whether you use a panel or not.

C-W-Up means CTRL + SUPER +

  • When I push CTRL + ALT + T - started LXTerminal. How I can make all new opening windows in Lubuntu in default open in full size (not F11)? Jun 9 '13 at 18:51
  • I insert your code to my lubuntu-rc.xml before last tag </openbox_config> - after restart this hotkeys not working. Jun 9 '13 at 19:03
  • You will have to insert these bindings somewhere between the <keyboard> </keyboard> tags. </openbox_config> marks the end of the configuration file. Please see here and here for more information. Jun 9 '13 at 20:02
  • As for starting all new windows of a specific application in a maximized state, you can find out more about this here. Jun 9 '13 at 20:03
  • You made my day! Your hotkeys and OBApps work great! Jun 9 '13 at 22:19

For completeness of this thread, I'm going to collate some information from elsewhere.

To edit the config file:

gedit ~/.config/openbox/lubuntu-rc.xml

To apply the changes:

openbox --reconfigure

And personally, I want windows key (or super key) + up to toggle maximization and W+down to minimize (or iconify), so I personally change

<keybind key="W-Up">         # HalfUpperScreen
  <action name="UnmaximizeFull"/>
  <action name="MoveResizeTo"><x>0</x><y>0</y><width>100%</width><height>50%</height></action>
<keybind key="W-Down">       # HalfLowerScreen
  <action name="UnmaximizeFull"/>
  <action name="MoveResizeTo"><x>0</x><y>-0</y><width>100%</width><height>50%</height></action>


<keybind key="W-Up">        # Maximize
  <action name="ToggleMaximize"/>
<keybind key="W-Down">      # Minimize
  <action name="Iconify"/>
  • <action name="ToggleMaximize"/> does not work on lxqt-rc.xml, but halfupper and halflowerscreen work.
    – Timo
    May 19 '21 at 7:46

To open all applications maximized (not full screen as with F11), place the following code between <applications> and </applications> in lubuntu-rc.xml:

<application type="normal">

This code is already present, but is commented out along with a lot of other useful options, in the applications section of lubuntu-rc.xml.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.