I currently have PHP 5.4.14-1~quantal+1 (cli) installed on my Ubuntu 13.04 I tried to install php5-curl but I have a dependency issue

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install php5-curl

"php5-curl : Depend: php5-common (= 5.4.9-4ubuntu2) but 5.4.14-1~quantal+1 should be installed"

Do someone has any idea how to fix this problem?

  • Perhaps try sudo apt-get install php5-curl php5-common – haneefmubarak Jun 8 '13 at 17:45

Sounds like a mirror hiccup. make sure to do:

sudo apt-get update 
sudo apt-get install php5-curl php5-common

PHP just recently upgraded and the mirror might have not synced correctly. If it continues try the next day, these things get solved quickly.

  • 1
    I think I've found the problem. I installed php with the ppa:ondrej/php5 repository. When I updated Ubuntu (12.10 > 13.04), this repository was commented in the sources.list. – Gilles Jun 9 '13 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.