I recently installed Ubuntu 12.04 alongside Win7 on my HP Pavillion dv6-2020eg.

Ubuntu does not recognize my ATI Mobility Radeon HD 4xxx graphics card. It just says "unknown" in the information box and also no additional drivers are found. On the other hand the graphics are all working fine, so that might not be a real problem. I also tried Ubuntu 13.04 with everything being just the same.

  • CPU: AMD Turion(tm) II Dual-Core Mobile M500 × 2
  • Kernel Linux 3.5.0-32-generic
  • Gnome 3.4.2

A second problem I am facing - issues with suspend mode - might be related to this. I would appreciate it if you could chime in on that other Q&A as well if you have any ideas what might be causing these symptoms.

| improve this question | | | | |

Well, I have a solution for the graphic card, because I answered hours before a question like that (install ati radeon 2400 hd pro on ubuntu 13.04):

Here you have the same question and some solutions:

Radeon HD 2000, 3000, 4000 on Ubuntu 12.04.2 and higher: fglrx (legacy) unsupported, what to do?

As I have found out (4850 here), you can't via any method install fglrx-legacy on stock ubuntu 12.10, even if you use catalyst 12.6 which supports our cards, because the x server that 12.10 uses (1.13) is not supported by catalyst 12.6 or older.

However, this is somewhat of a solution, that I can confirm works on my machine: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Just follow that (well, uninstall any fglrx you have installed now first), and you should have a better experience.

I should note, you will be downgrading your x server to version 1.12, and these packages are not supported by ubuntu, but this is the closest to a "solution" as can possibly exist at this time.

I hope this helps some!

| improve this answer | | | | |
  • Well, there's now a driver installed for my graphic card, called VESA:M96. Unfortunately, the suspension mode is still not working, so I guess the two problems are not related. I'll just change the topic. Thanks for your help! You solved part of the problem. :) – narf Jun 8 '13 at 18:05
  • I think is better to mark this as solved and start a new question with the suspend problem only, because you are going to have answers for both questions here then. – Leo Jun 8 '13 at 18:13
  • you're right. bye – narf Jun 8 '13 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.