I'm trying to install 13.04 64-bit server on an AMD Fusion based System (C60M1-i). Installation medium is a USB Stick created with unetbootin (or, better: several of them already).

Ubuntu Live boots well, only after installing Server/Desktop I get a black screen

Missing operation system.

Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key

I already - tried diverse downloaded Images (including Raring Desktop) - partioned the disk using GPT - ran boot-repair

boot-repair log: http://paste.ubuntu.com/5745089

to no avail.

But the EFI doesn't recognise the bootdisk (Sandisk SSD) as bootable (doesn't show as UEFI: Sandisk P4... in the Mainboard Setup).

I have no control over secure boot (Mainboard doesn't offer an option).

How could i get this system booting? I actually wouldn't care booting Legacy (BIOS) in the end...

Thank you for any advice.

Best Constantin

Edit #3: It seems that the problem is, that efibootmgr cannot write the boot-entry to the NVRAM (seems like a bug with some or many EFI boards, at least it is mentioned with different ASUS models on the web. Some folks mention a bug in efibootmgr as well ... will try to figure out). I for now sort of worked around it by placing a copy of grubx64.efi to the root of the EFI partition and then from the mainboard setup call 'Start EFI Shell from filesystem'. E voilá - there's grub and I can boot. Will need to find a complete solution, still.

Edit #4: Might have to do with this: Sony VAIO with Insyde H2O EFI bios will not boot into GRUB EFI

  • What are you trying to achieve? Is it a clean Ubuntu install or a dual boot setup? – Alvar Jun 8 '13 at 14:13
  • Clean. Freshly partitioned SSD. (GPT) – Costa Jun 8 '13 at 15:20
  • It sounds like you are not using EFI, but are booting in BIOS mode, and you didn't create a bios_grub partition so installing grub failed. You would have gotten an error message to that effect when installing. Try again and make a 1 MiB bios_grub type partition. – psusi Jun 8 '13 at 17:45
  • No. It was and is installed in EFI Mode. See 'Edit #3'. – Costa Jun 9 '13 at 10:50
  • It's most likely related to this: askubuntu.com/questions/286462/… – Costa Jun 9 '13 at 14:57

You could try using bcfg from an EFI version 2 shell:

  1. Download an EFI version 2 shell. Here is a link to a semi-official binary. If that binary hangs, try this one, but note that you'll need to unzip the shell program from the zip file. (The second program should work on older computers, which the first one doesn't support.)
  2. Create a USB flash drive with a FAT partition.
  3. Copy the EFI shell to the USB flash drive as EFI/BOOT/bootx64.efi on the flash drive. For instance, if you mount the flash drive at /media/flash, the file should be /media/flash/EFI/BOOT/bootx64.efi.
  4. Reboot and tell your computer to boot from the USB flash drive.
  5. In the EFI shell, type bcfg boot dump -v to see the current boot entries. Note the highest number in the existing boot entries.
  6. Add a new boot entry using bcfg boot add 3 fs0:\EFI\ubuntu\grubx64.efi "Ubuntu", changing 3 to a value higher than any in the list you got from the previous step.
  7. Type bcfg boot mv 3 0 to make GRUB the default boot entry. (Change 3 to the number you used in the previous step.)

When you reboot normally, the computer should boot into GRUB by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.