3

This question already has an answer here:

I have a bash script that has permission to execute, but when I double click it in nautilus it won't execute, instead it opens as text in gedit.

In properties it says open with: gedit, and that doesn't change when I click the reset button.

What do I have to do to make it execute? I'm running Ubuntu 13.04. I never had an issue like this one with 12.04 or with any other distribution in general.

EDIT If I go in terminal and type: ./bashscriptname it runs just fine.

marked as duplicate by pomsky, Zanna, Kulfy, Eric Carvalho, Fabby May 3 at 22:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

14
  1. Open Nautilus.
  2. Go to FilePreferences (in Ubuntu 14.04, you might find it under EditPreferences).

    enter image description here

  3. Go to the Behavior tab and click on Run executable text files when they are opened.

    enter image description here

    Or, choose Ask each time to be prompted every time you double click.

  • 1
    I'm not all that familiar with Ubuntu, but on a fresh install of Ubuntu 14.04, I had to go to the "Edit" menu to find "Preferences". – Nick Jul 24 '14 at 4:45
  • 1
    @Nick I've updated my answer to include that. Thanks. – Alaa Ali Jul 24 '14 at 11:07
1

As mentioned in this blog post here,

Open file explorer Files. Press Alt+F10 and select Preferences. It should show something like this

enter image description here

In the Behavior tab, select Ask each time and close it. By default, it will be in View executable text files when they are opened. Now whenever you double click on a shell script, it will ask you what to do. If you want to straight away execute the script, select the first option Run executable text files when they are opened

Not the answer you're looking for? Browse other questions tagged or ask your own question.