1

could anyone help me, please, to install an ati radeon 2400 hd pro on my ubuntu 13.04? i tried using the info from this site http://www.noobslab.com/2013/04/install-ati-amd-catalyst-drivers-in.html. but it says is not compatible, so i was thinking if there is another way. i'm a begginer in using ubuntu, so if anyone could help me, it would be great. thanks

1

Legacy drivers for these cards are available. Unfortunately these legacy drivers (version 12.6) have not been updated.

So if you want to install these drivers, you have to downgrade to xorg 1.12. To do that, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install fglrx-legacy

If you encounter any problems with these drivers, you can remove these drivers, by running following commands:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx

Source:Launchpad

| improve this answer | |
  • 1) "E: Some index files failed to download. They have been ignored, or old ones used instead." 2) Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package fglrx-legacy – Yevgeniy Afanasyev Jul 26 '15 at 23:31
  • @YevgeniyAfanasyev Which Ubuntu release are you running? – Mitch Jul 27 '15 at 5:27
  • Thank you for asking. It is Ubuntu 15.04. it is not the same as in the question, probably it is a reason. I asked another question here: askubuntu.com/questions/653166/… – Yevgeniy Afanasyev Jul 27 '15 at 6:21
0

Here you have the same question and some solutions:

Radeon HD 2000, 3000, 4000 on Ubuntu 12.04.2 and higher: fglrx (legacy) unsupported, what to do?

As I have found out (4850 here), you can't via any method install fglrx-legacy on stock ubuntu 12.10, even if you use catalyst 12.6 which supports our cards, because the x server that 12.10 uses (1.13) is not supported by catalyst 12.6 or older.

However, this is somewhat of a solution, that I can confirm works on my machine: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Just follow that (well, uninstall any fglrx you have installed now first), and you should have a better experience.

I should note, you will be downgrading your x server to version 1.12, and these packages are not supported by ubuntu, but this is the closest to a "solution" as can possibly exist at this time.

I hope this helps some!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.