I've just installed Ubuntu 13.04 and I think I may have issues with the graphic card.
Its fan is just running very fast (and noisy).
I tried to check the temperature using sensors and got the following:

Adapter: ISA adapter
Core 0:       +48.0°C  (high = +84.0°C, crit = +100.0°C)
Core 1:       +47.0°C  (high = +84.0°C, crit = +100.0°C)
Core 2:       +46.0°C  (high = +84.0°C, crit = +100.0°C)
Core 3:       +47.0°C  (high = +84.0°C, crit = +100.0°C)

Adapter: ISA adapter
in0:          +1.12 V  (min =  +0.00 V, max =  +4.08 V)
in1:          +1.89 V  (min =  +0.00 V, max =  +4.08 V)
in2:          +3.30 V  (min =  +0.00 V, max =  +4.08 V)
+5V:          +2.99 V  (min =  +0.00 V, max =  +4.08 V)
in4:          +0.45 V  (min =  +0.00 V, max =  +4.08 V)
in5:          +0.11 V  (min =  +0.00 V, max =  +4.08 V)
in6:          +0.10 V  (min =  +0.00 V, max =  +4.08 V)
in7:          +3.20 V  (min =  +0.00 V, max =  +4.08 V)
Vbat:         +3.28 V  
fan1:           0 RPM  (min =    0 RPM)
fan2:           0 RPM  (min =    0 RPM)
fan3:         477 RPM  (min =    0 RPM)
fan4:           0 RPM  (min =    0 RPM)
temp1:        +44.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp2:        +43.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermal diode
temp3:         -2.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
intrusion0:  ALARM

Adapter: PCI adapter
temp1:       +113.0°C 

IIUC - the temperature is 113.0C is this a normal temperature? Is this why the fan is running fast? Until yesterday I had Windows 7 on this same machine and I haven't had any problems with the GPU fan.
Might be a drivers issue, I tried to install the driver for AMD/ATI web site and failed (something about required packages missing - checked the logs to see what is missing and found out it is installed).
I'd appreciate any help here.



As I said here: Overheating on VAIO SB36

Usually, the overheating problem in Ubuntu is related to the graphic card, and in your case, you have an Hybrid graphic card with the open source drivers. In this case, by default, you have both graphic cards connected but you are only using the integrated (Intel). If you want to use only one and when you want, you need to install the privative drivers following this answer:

What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD?

And using the latest driver:

(6 jun) http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13-4-linux-x86.x86_64.zip

The problem is that the latest stable driver from AMD is not compatible with the last version of Ubuntu with the latest version of the Xorg Server. Download the latest beta driver which is compatible with Ubuntu 13.04:


You can try to install it, but as you can see, the privative driver is not compatible with 4XXX series: http://support.amd.com/us/kbarticles/Pages/AMDCatalyst13-6LINBetaDriver.aspx

Also I found this: Radeon HD 2000, 3000, 4000 on Ubuntu 12.04.2 and higher: fglrx (legacy) unsupported, what to do?

As I have found out (4850 here), you can't via any method install fglrx-legacy on stock ubuntu 12.10, even if you use catalyst 12.6 which supports our cards, because the x server that 12.10 uses (1.13) is not supported by catalyst 12.6 or older.

However, this is somewhat of a solution, that I can confirm works on my machine: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Just follow that (well, uninstall any fglrx you have installed now first), and you should have a better experience.

I should note, you will be downgrading your x server to version 1.12, and these packages are not supported by ubuntu, but this is the closest to a "solution" as can possibly exist at this time.

I hope this helps some!


This is assuming if you have a hybrid graphics card, that is, an integrated Intel graphics and dedicated ATI graphics card.

Also assuming you're using the open-source radeon driver, not fglrx

This may be a bit late, but you can check out https://help.ubuntu.com/community/HybridGraphics to use vga_switcheroo to turn off your dedicated graphics.

If you ran sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch and got file not found, try executing dmesg | egrep 'radeon|switcheroo' which managed to get it toggled on for me.

Now just run sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch to switch off the dedicated graphics. My laptop dropped 20 degrees Celsius when I did that. :)

Note that you have to run all this everytime you boot up, unless you want to go the extra step of configuring it to perform automatically, which I have not tried.

additional stuff

You may also wish to install tlp. http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html The default settings for tlp were enough to bring my laptop as cold as Windows ever did, if not better. That is pretty cool, considering I could burn my hand just touching my laptop vents previously.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.