I have upgraded to 13.04 and lose disk space, ... I have a 3 TB hard disk, and had yesterday still 890 GB free, ... today all is gone!

Disk Usage Analyzer does not give me a clue and says that it could not read all directories due to missing permission. How can I start it as root, believing that this would give me all permissions.

Log files don't show me also anything useful for that matter.

  • give us the output of lsblk – jet Jun 8 '13 at 17:07

To run a graphical application as root, you would use the commands gksu or gksudo. However, these have been removed from Ubuntu 13.04 for various reasons.

So, in order to run Disk Usage Analyzer as root, here are two methods:

Method 1

  1. Open a terminal, Ctrl+Alt+T. Type sudo apt-get install gksu, this will install gksu and gksudo.
  2. To run Disk Usage Analyzer as root, do the following command:

    gksudo baobab

Method 2

  1. Open a terminal, Ctrl+Alt+T. Type sudo -i. This will log you in as root in the terminal.
  2. Run Disk Usage Analyzer by typing:


In both cases, don't close the terminal until you are done, because closing the terminal will also close Disk Usage Analyzer.

Further to your problem, you can use the command df -h to show you the sizes of your partitions and see how much space is available.

| improve this answer | |
  • I cannot install any program, since ZERO bytes are free!!! second way worked, but I have no idea how to figure out what to do next. I cannot figure out who fills up my harddisk and how to stop it, ... any hints???? – Ronald Jun 8 '13 at 10:39
  • Mount all of your partitions, and look at the output of Disk Usage Analyzer. Sort it by size. See which folders have used up the space, and which folders looks suspicious. You know your computer best. I doubt 890GBs can be used up just like that. Where was this 890GB space? Was it a separate partition? Unallocated space? Part of another partition? Part of the Ubuntu partition? Edit your question to include the output of df -h and sudo parted -l. – Alaa Ali Jun 8 '13 at 12:39
  • I found something: in my home directory was a file .xsession-errors, with 1,357 GB !!!! tail of this PM Authentication deferred - ignoring client message I used cp /dev/null .xsession-errors to clear it It starts immediately to fill it up with the same error!! How can I fix that? – Ronald Jun 8 '13 at 14:11

On Ubuntu 18.04 at least, running the Disk Usage Analyzer as root can be done from the terminal simply with this:

sudo baobab

Additionally, you can use a command-line tool which works very well, called ncdu. It's very intuitive and easy to use. Run it with:

sudo ncdu

sudo may not even be required for it. For a help menu while in ncdu, press Shift + ?.

Note that I believe ncdu stands for "ncurses Disk Usage", where ncurses is the library or tool that makes an interactive, graphics-like interface possible in the terminal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.