I recently installed Ubuntu 13.04 on my new Acer Aspire V5-121 Netbook. The first thing I noticed was that the touchpad does not work. It does not recognize clicks or touches. How do I find out what's wrong, and fix it?

I did not find any proprietary drivers for the Touchpad offered by Ubuntu. The package xserver-xorg-input-synaptics is already installed.

xinput list shows the following:

    $ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PixArt Microsoft USB Optical Mouse        id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Video Bus                                 id=7    [slave  keyboard (3)]
↳ Power Button                              id=8    [slave  keyboard (3)]
↳ Sleep Button                              id=9    [slave  keyboard (3)]
↳ HD WebCam                                 id=11   [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
↳ Acer WMI hotkeys                          id=14   [slave  keyboard (3)]

I've already tried the solutions outlined here, for a somewhat similiar issue: Touchpad stopped working on an Acer AspireOne D255E . But the solutions outlined here did not help.

Edit: I found a solution. Apparently it was just disabled by the system. Even though I'd turned off the option to disable touchpad when mouse is plugged in, it was disabled for some reason.

Solution: Press Ctrl-Fn-F7.


My issue was solved by pressing the key combo Ctrl-Fn-F7. I had tried the combo Fn-F7 but that did not do anything.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.