0

I see answers for older versions, but the same process doesn't seem to work in 13.04. I have tried System Settings... the compiz config manager and the new unity tweak tool. They all report that I have disabled the HUD key but the HUD keeps popping up with Alt. I also tried setting it to a different key and Alt continues to cause the HUD to come up.

1
  • Success! I needed to disable the hotkey to "give keyboard focus to the launcher". Then fix the keymap settings that ccsm seems to have screwed up simply by running it. But now I can use alt- hotkeys in Emacs again, whew. Jun 7, 2013 at 15:43

2 Answers 2

2

I just tried it in CCSM in 13.04 and disabling works. Here's what I do.

  1. Open ccsm and select the Ubuntu Unity plugin. enter image description here

  2. Click the Edit button (Pencil icon) and in the dialog that appears, delete the text. Just leave it empty and click save.

  3. That's all. You should see now that the HUD shortcut is disabled. enter image description here
4
  • Yes, when I do that it says 'Disabled'. But it is not disabled, 'Alt' continues to bring up the HUD. Jun 7, 2013 at 14:54
  • that's weird. i just tried it on my PC and it works
    – llt
    Jun 11, 2013 at 3:37
  • +1 Because this is the only solution that works for Ubuntu 14
    – yPhil
    Aug 11, 2014 at 11:47
  • Strangely, for me, 'Alt' continued to bring up that 'Search this computer'. I finally ended up deleting most/all of the shortcuts under the 'Ubuntu Unity Plugin' and that seemed to resolve the issue for me. I'm not sure why there are so many shortcuts. I think most of them are unnecessary, since most users will simply use the GUI to do what they and the power users will set up the shortcuts that they want to use. Configuring something so basic as the 'Alt' key to globally bring up the 'Search this computer' seems unwise since many applications, including Emacs, uses Alt key combinations..
    – Gino
    Sep 23, 2016 at 14:57
2

I. Install Ubuntu Tweak

sudo apt-get install unity-tweak-tool

II. Open it and go to Unity > Additional

Unity Tweak Tool

III. Change keyboard key to invoke HUD or disable it with backspace

Change Alt key to invoke HUD

IV. Log out

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.