I have been troubleshooting my HP EliteBook with BCM4322 14e4:432b wireless card. I am using Linux kernel 3.9 and I have almost found the solution. Reading on the Linux Wireless site, I found that the b43 and wl drivers should work at least somewhat with the card. I was unable to get things working using kmod-wl, and so I moved on to working with b43. I followed the guide here, and got it working using these lines of code:

modprobe -r b43 bcma
modprobe -r brcmsmac bcma
modprobe -r wl
modprobe b43

When I restart the computer, I have to do this again to get things working. I know I am supposed to blacklist the unwanted modules, but adding brcmsmac and wl to the blacklist.conf file does not seem to work. How can I get this to work permanently?

  • Sorry, I do not mean to answer, merely wanted to ask this in a comment, but I do not yet have enough reputation to be able to comment. When you added brcmsmac and wl to blacklist.conf - Did you add them as install brcmsmac /bin/false or blacklist brcmsmac ? What happens if you try the other method?
    – Vuade
    Jun 7, 2013 at 8:04
  • I think I have found that my problem is that b43 is not loading at startup. I only have brcmsmac and wl blacklisted and b43 does not load at startup. I am going to try a fresh OS install, update, and then try again. I had originally tried using the proprietary driver first and I think that messed things up. Jun 7, 2013 at 13:20
  • SOLVED: I did a fresh OS install, followed directions on wireless.kernel.org/en/users/Drivers/b43 and blacklisted only ssb. Thanks for everyone's help! Jun 7, 2013 at 13:44
  • I've looked through the answer at the above duplicate-as-marked URL, but found it circuitous in regard to the very specific problem of having to modprobe b43 every boot. The answer for my system was simple: broadcom-sta-common blacklists the b43 module, so purging the broadcom-sta-* files instantly resolved the problem.
    – Gnaural
    Jun 13, 2017 at 13:58

1 Answer 1


If the blacklisting does not work then the module might be loaded early in the initframfs. Take a look at the file /etc/initramfs-tools/modules.

What is the content of /etc/modules? Also please post the lines you used to blacklist the modules.



I found the following command on the b43 homepage:

sudo apt-get install firmware-b43-installer

Have you tried that?

On the other hand, if you want to have your module loaded at run-time, add the following line to /etc/modules:


to /etc/modprobe.d/blacklist.conf

blacklist brcmsmac and blacklist wl

then reboot the machine.

The module should be loaded then.


Not the answer you're looking for? Browse other questions tagged .