13

I have a very interesting problem that has just recently developed.

I am routinely getting software updates and I can see the software updater window is available to be displayed on the task bar in unity, but when I click on it I cannot get it to display.

The only way that I can get the updates to install is to right click on the task bar icon and advise it to install updates. I can not bring the update window up to see what I am installing.... :O (Hope I don't break it!) ;)

I have been searching around the forums and have not seen an issue that quite compares - so now I ask my friends on the Web.

Is there some way I can make this window display? I feel it is likely a setting in a config file somewhere on the system that I cannot identify.

Some interesting points to supply:

  1. AMD 6 Core processor
  2. 8 gig ram
  3. Gigabyte board with onboard AMD graphics
  4. 1 terabyte drive
  5. Dual 1080P monitors

NO dual boot to Windows.

System was built and Ubuntu 12.10 was originally installed, with a subsequent upgrade to 13.04

I recently tried to install the AMD raedon drivers and broke it - so I reversed back and now run the stock driver (Not sure which one).

I can't recall if my issue started before this amd issue, or if was going on before that - I think they may be related.

The only way I can access this active window is via right click - it never shows on the desktop!

7
  • 1
    Me and all my co-workers have this issue too. – mpen Jul 11 '13 at 23:28
  • 2
    I have the same problem on 14.04. ATI Radeon HD5450 512 MB by Sapphire. – Walter Tross Jun 14 '14 at 9:10
  • 5
    It's a bug, linked in an answer. Workaround: wmctrl -R 'Software Updater' – nafg Aug 25 '14 at 5:14
  • Seeing the same issue on 14.04 with graphics described as Gallium 0.4 on AMD CEDAR. There's a lot of AMD on this thread. Anyone have a counterexample? – Drew Noakes Oct 16 '14 at 9:13
  • Yes, this happened to be on 14.10 with intel i915 GM4500 graphics. Its likely not AMD specific. 'wmctrl -R' fixed it. – clemej Jan 3 '15 at 14:21
8

I am having the same problem on my system.

Freshly installed Ubuntu 13.04 from scratch, no dual boot, no upgrade from previous version.

AMD video card, ATI Radeon HD 5700 - using ATI's Catalyst Drivers v 12.9

Multiple monitors, 2 1080p screens, one 1280x1024

to get around the issue when there are new updates that it automatically scans for, I right click the icon on the taskbar, quit the software, and then start it again from the unity menu manually and the window will show up.... so it's not that big of a pain there is a workaround....

but I have another Ubuntu 13.04 machine right next to me and that one does show this window.... ( that system was also freshly installed 13.04, but single monitor, AMD Radeon HD 7500, Catalyst 12.9 ).

I've also noticed on the system that isn't showing the window, no matter what virtual desktop I'm on, clicking the icon doesn't switch desktops to where the window would be located, so I imagine that means the window does not even exist ( if it was perhaps out of my viewscreen coordinates... ). Other windows that are present on other virtual desktops do what I expect when clicking their icon - they switch the virtual desktop to the one with the active window....

What other information could be pertinent to this issue?

maybe related/similar to:

https://bugs.launchpad.net/unity/+bug/1003950 https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1001067

1
  • 1
    I think having dual monitors is the issue. Not sure about 13.04 but in 14.04 dual-monitor support is horrible. – Lambart Oct 16 '14 at 17:08
1

Same problem here, but the window is sometimes hidden, sometimes it is not. Unfortunately there is no obvious reason. One thing in common, I also have an AMD APU with onboard Radeon graphics (AMD Radeon HD7420G = HD7500M/7600M Series)

Also I can use the window if I start the Software Updater manually.

0

I'm also having this problem, also with an AMD GPU. My current drivers are fglrx 13.10.10 [May 23 2013]. A workaround is to run Software Updater from Unity.

2x 1TB drives

8 GB memory

dual boot windows 8.1 (each OS has its own physical drive)

AMD Radeon 5850

Software Updater has appeared in the past, though it seems set on not showing itself right now. I can interact with the it right clicking on the icon in the dock and choosing update software. Quitting the updater and opening through Unity fixes the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.