I'm using DOSBox 0.74, which works properly and can successfully mount a "c" drive. However, I don't know how to mount a dvd drive. I'm trying to install Star Control 3 from a disk so that I can play it with DOSBox, but I can't mount the "d" drive. I've tried mount d /media/cdrom0 -t cdrom which http://www.ubuntugeek.com/howto-auto-mount-a-drive-in-dosbox.html claimed would work. I've looked at http://www.dosbox.com/wiki/MOUNT#Linux but I didn't understand what exactly it was saying.

So I guess what I'm really asking is does anyone know what commands to use to mount a CD/DVD using DOSBox in Ubuntu 12.04?

  • Is your CD/DVD drive mounted at /media/cdrom0 in your "outer" Ubuntu system? I've only used CDs in DOSBox on an OSX host (my Ubuntu system has no CD/DVD drive), but my leftover config files all have normal folder paths in the mount commands rather than devices. Since that tutorial is almost 6 years old, it's possible that the mount point convention has changed. – Paul Jun 7 '13 at 0:19

Check that you really have the CD/DVD mounted on that location, as usually the CD label is used instead, then run:

mount d /media/LABEL -t cdrom -label LABEL -ioctl -usecd 0

Just replace LABEL with whatever you have. Tested it on Dosbox 0.74 on Ubuntu 12.04.

| improve this answer | |
  • When I type mount d /media/STARCON3 -t cdrom -label STARCON3 -ioctl -usecd 0 I get the same "Directory /media/STARCON3 doesn't exist" Am I still missing something? – Charles German Jun 8 '13 at 0:59
  • That is all. Worked for me. It is case sensitive. You could try adding an extra slash /media/STARCON3/ or quotes "/media/STARCON3/" – Osolong Jun 8 '13 at 1:43
  • I've tried mount d /media/STARCON3/ -t cdrom -label STARCON3 -ioctl -usecd 0 and mount d "/media/STARCON3/" -t cdrom -label STARCON3 -ioctl -usecd 0 and mount d /media/STARCON3/ as well as mount d "/media/STARCON3/" and I still get the Directory /media/STARCON3/ doesn't exist.` I'm thinking now that perhaps I don't have the correct name for my DVD drive, is there any way to check that? – Charles German Jun 8 '13 at 14:32
  • Type mount and you should see where it mounted your CD. Sometimes it is mounted on /media/user/label/. If is not present, try mounting it manually or check the following posts. Cannot mount DVD/CD How to find mount point – Osolong Jun 10 '13 at 13:23
  • looking at the output of mount in the terminal gave me exactly what I needed, thanks! – Charles German Jun 12 '13 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.