5

Currently, each time I restart my Ubuntu Server, it's prompting for a login password. How do I disable this feature so that I when I restart my Ubuntu server, it doesn't require me to enter credentials?

Version: Ubuntu 12.04.2 LTS

  • I'm curious. Why would you want to do that? – hmayag Jun 6 '13 at 20:38
  • 1
    say for instance, while I am in development stage and want to save time. – c 2 Feb 25 '16 at 17:16
8

Is not a secure procedure and you are not going to obtain anything with it (the processes are started before login), but well, these are the steps:

To enable automatic login in Ubuntu server we need to edit the tty1 configuration file. To open this file up in nano use the following command:

sudo nano /etc/init/tty1.conf

The very last line in this file should start with an exec command. Delete this line and replace it with the following:

exec /bin/login -f USERNAME < /dev/tty1 > /dev/tty1 2>&1

Note that you need to change USERNAME to the username of the user that you want to be automatically logged in. Once you reboot your system you should be automatically logged in.

Source: http://nixgeeks.com/how-to-enable-automatic-login-in-ubuntu-server/

| improve this answer | |
  • Thanks for the response. But isn't it a stand procedure? Don't a lot of hosting servers out there allow you to restart instances without having to log in again? – c 2 Jun 6 '13 at 20:40
  • 1
    If the program you are running on your server starts up automatically (e.g. via crontab), you don't need to log in when your computer starts up. I never log into my ubuntu server computer when I boot up, and whenever I need to administer I use ssh. – daboross Jun 6 '13 at 20:53
  • Are processes really started before login? Does this require somekind of configuration? My user-specific cronjobs don't run unless I login. – quano Dec 19 '13 at 12:25
  • Hm nm, I think that has to do with the home folder encryption in ubuntu. – quano Dec 19 '13 at 12:53
  • Doesn't work for ubu desktop 12.04 lts. link's dead – Wolfpack'08 Jan 19 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.