14

I want to install more text fonts on Gimp. Currently I have only the default fonts.

Where can I download and install them?

I am on Ubuntu 13.04, using gnome - lastest version.

1
22

All you need to do is: add the fonts that you want to Ubuntu, and then you can use them in Gimp.

Download the font(s) that you like, and once downloaded, you can double click on the font file, and that will open Font Viewer, just click on install, and you're done. Take a look at Dafont for a great selection of fonts.

enter image description here

To download, just click on the download button.

enter image description here

Once you click download you will see the image below, just click OK.

enter image description here

Double click the font, and that will open the Font viewer, as shown above, just click on Install.

enter image description here

3
  • I would like to add how to install the fonts from that website. When I will be able to add a new font, I will mark this answer. Thanks! Jun 6 '13 at 19:20
  • Just added it to the answer.
    – Mitch
    Jun 6 '13 at 19:41
  • Thanks, it works! +1, because you are a Firefox fan like me. :-) Jun 7 '13 at 3:47
9

For some reason, on Ubuntu 19.04 + GIMP 2.10 after installing the font in Ubuntu it did not appear in Gimp, not after restarting Gimp, nor restarting the system itself. What solved the problem was to copy the .TTF font file to one of GIMP fonts directory. Font directories can be managed in Edit > Preferences > Directories > Fonts menu. In my case, that directory was /home/snap/gimp/227/.config/GIMP/2.10/fonts.

2
  • 2
    This might be a tickle-point, but for me this is under Edit > Preferences > Folders > Fonts.
    – sas08
    May 1 '20 at 17:36
  • I guess the move to snap is the problem here: isn't that a sandboxed environment; which presumably makes accessing system files less straightforward?
    – blindfish
    May 13 at 21:23
3

in general

  • TTF go to ~/.local/share/fonts/TTF/

  • OTF go to ~/.local/share/fonts/OTF/

for gimp only

  • ~/.gimp-2.8/fonts/

see docs

1
  • 1
    I am using Gimp 2.10 and my gimp font directory is ~/.config/GIMP/2.10/fonts Dec 25 '18 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.