10

I am able to run sessions over an ssh connection but I rather use the "Ubuntu classic desktop (no effects)" version on Ubuntu 11.04 instead of the new Unity since I don't have 3d support on the laptop I'm using to display the graphical User Interface. How can I startup the older gnome-session without the 3d effects? I tried gnome-session but it seems to be the option with the 3d effects and I want a more stripped down session over my ssh session.

  • What exactly are you trying to achieve? Invoke GNOME applications over ssh from another machine? – Adam Byrtek Mar 15 '11 at 21:58
  • I'm trying to invoke a full Gnome session so that I can use the Gnome menus and notifications on screen to invoke different applications. I want it to be the same as when I login to my desktop using the "Ubuntu classic desktop (no effects) without needing to be sitting at my desktop. – Andrew Stern Mar 16 '11 at 17:57
8

From the command line the GNOME Classic Desktop is started with:

gnome-session --session=gnome-classic

Other session types are installed by default in /usr/share/gnome-session/sessions/ and can also be opened with the gnome-session --session=SESSION command where SESSION is the name of the SESSION.session file stored.

  • The correct path seems to be '/usr/share/gnome-session/sessions/' and I see the following in the directory: 2d-gnome.session classic-gnome.session gnome.session ubuntu.session – Andrew Stern Apr 6 '11 at 16:33
  • Note that the version 11.10 doesn't have the classic-gnome by default so you have to use 'ubuntu-2d' instead. – Andrew Stern Oct 14 '11 at 23:16
  • Note I found this to readd the classic gnome desktop: liberiangeek.net/2011/08/… – Andrew Stern Oct 14 '11 at 23:18
  • I tried those, and none of them worked – anonnymouse Jul 11 '18 at 5:39
  • @anonnymouse: we can only call sessions that are predefined in our system. The answer was valid in 2011 but today we need to install the gnome-session-flashback package and then may be able to call this session with gnome-session --session=gnome-flashback-metacity (can't try atm, if it works I'll edit my answer later) – Takkat Jul 11 '18 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.