I am having the same problem as Clean Install of Ubuntu won't boot [reboot and select proper boot device] where a fresh Ubuntu install completes but will not boot.

I get a Reboot and select proper boot device error, first with Xubuntu 13.10, later with Xubuntu 13.04, and finally also with Ubuntu 13.04. Asus motherboard Z77, Intel chipset. Standard internal SATA 500GB HD. 64-bit. It was running Ubuntu 12.04LTC until I tried this upgrade.

I have re-installed Ubuntu 13.04 from scratch different ways:

  • with LVM,
  • without LVM,
  • with the default partitions,
  • with my own partitions,
  • with ext3 or ext4,
  • alongside,
  • replace,
  • run boot-repair from USB installation media
  • upgrade,
  • run boot-repair again

No difference.

This starts from the ubuntu-13.04-desktop-amd64.iso and UNetbootin as suggested on the official instructions for USB thumb drive creation from OS X. That part all works fine (booting the USB on the PC and trying Ubuntu and/or installing from there on the PC HD.) I have no CD drive on this PC, but I suppose I could get one. I would rather find some Linux install that works from USB like I've always done.

After running boot-repair twice, in the Asus BIOS I now see three different UEFI boot options in the priority list, and they are all labelled exactly the same:

ubuntu (P6: WDC WD5000AAKX-00U6AA0)

Then there's a non-UEFI option:

P6: WDC WD5000AAKX-00U6AA0 (476940MB)

And a fifth option appeared after the first boot-repair:

Windows Boot Manager (P6: WDC WD5000AAKX-00U6AA0)

I have tried all 5 of these, and I get exactly the same error.

I have never had Windows installed on this HD. Asus is calling it Windows Boot Manager but I presume that's a mistaken label for whatever boot-repair did.

I can boot on USB and run GParted and it looks great. The partitions all look normal.

Needs a master boot record wipe/redo?

  • I flashed the system BIOS and that made no difference. I also did some random hardware troubleshooting: removed and re-seated RAM, moved the drive to a different SATA port, unplugged and redid all connections, etc. Did another fresh install. No change. Going to hunt some other distro incl. maybe back to 12.04.
    – IcarusNM
    Jun 5, 2013 at 18:46

2 Answers 2


Solution: Update the ASUS BIOS with a newer version.

The great support team at Boot-Repair concluded this was a UEFI bug with my BIOS. I did update the BIOS near the end of all this, so apparently that did something good.

I also seemed to have better luck generating the installation USB from within Ubuntu itself rather than from a Mac using UNetbootin, but that may not have anything to do with it.

  • 1
    Worked, after updating my bios the error was resolved.
    – Hyperfocus
    Jan 15, 2015 at 12:22

Get your priorities in order.... your boot option priorities that is.

After upgrading I saw 2 boot options in the bios marked "ubuntu (PO: ST9500420AS". I selected the 2nd one as the first boot disk and it started working.

I suspect upgrading the bios might have fixed the boot option priorities by luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .