So, I've done many many different installations of linux and hit this road block EVERY TIME. Though, this time, it is really turning into a pain. I have indeed tried every common method so far, so don't ask if I did. I tried installing the ones that Ubuntu provides, I reboot... black screen (with backlight on). I tried the x-swat ones, (which i had to use in the past to make it work) same thing- black screen with the backlight on. i installed the binary drivers from the official page, and after jumping through a MILLION hoops to finally get nouveau to NOT load.... black screen! hooray! This is really a wonderful birthday present lol.

In all seriousness, here are a few specs:

Specs you probably wont need: i5 3570k 16GB RAM 120GB SSD Asrock extreme4 z77

Specs that are actually important: nVidia GTX 660 Ti Ubuntu 13.04, 64 bit current (also non working) driver: 319.23

my xorg.conf looks like this (ran nvidia-xconfig):


and i added nouveau to blacklist.conf in modprobe.d

after all of this i can only get the desktop environment to start normally in a failsafe x, under recovery. and at that point, things start acting weird (my steam which was working BEFORE this fiasco, now can't find it's 32bit libraries which I selected to install with the nvidia driver and i know are there)

so yeah, with all of that, can anyone tell me WHAT THE HECK im doing wrong =P ive had one problem after another this time around, almost bricked my harddrives because of a messy uefi issue that popped up (unrelated to this, but still took half a day to clear up). I know it's a duplicate, ive been searching the same question for hours, but none of them have worked. But, I dont really want to give up on this. I'm a gamer gosh darn it!

  • Did you try 310 version of driver? If yes to what effect? From what i see from the xorg file you have two cards defined and all are connected to the same monitor.There should be only one Screen0 and Monitor0 and Device0 so please try to remove duplicate entries. Also please try to remove xorg file and see what happens. – Misery Jun 5 '13 at 6:25
  • 310 was i believe the first one i tried. and i have tried taking away xorg.conf. it gave me the same result, unfortunately. – Tony Jun 5 '13 at 6:58
  • so try removing duplicate entries from it and save it, then restart xserver or reboot. – Misery Jun 5 '13 at 7:10
  • so basically- heres what happened. I installed 310.... and got that screen again. But, I took a chance and things worked out well. See, I encrypted my harddrive, so, I have a screen that usually asks for my encryption password. it's THAT screen that doesnt show up. But, if i successfully enter my password without a screen, It will continue on and actually load. which is really weird. So i guess now my question is how to get the encryption screen to show up. – Tony Jun 5 '13 at 16:47
  • also, to anyone reading this. there weren't duplicates of devices in the xorg.conf. if im reading it correctly all the refrences in the beginning are defining the parameters of the devices. If i took any duplicates out, it did really nasty things, and gave me a ton of errors. So don't go screwing around with xorg.conf unless you REALLY know what you are doing – Tony Jun 5 '13 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.