20

I have Ubuntu 13.04 Gnome with Mate.

If I click on the networking icon on the top tool bar and try to do something like add a never before used Wifi or simply click Hardwire Connection 1 when I have changed to a new network, I get 'Connection activation failed. (32) Not authorized to control networking.'

My presumption is that I have lacking some group attribute for my user or else there is some security setting.

I can make the changes if I log in as root instead of myself.

What must be tweaked to allow my user name the privileges to handle this?

15

To fix this problem, it should be enough to add your user to the network or netdev group. To do it, you can use the GUI in the settings menu (that cog in the top right), or just type something like this in a terminal:

sudo usermod -G netdev -a yourusername

Remember to logout/login again to update your user privileges.

9
  • Now that's interesting. There does not seem to be a network group at all. That strikes me as indicative of a deeper problem...
    – Dale Amon
    Jun 6 '13 at 0:48
  • 1
    I've approved an edit changing the group from network to netdev. (The edit was anonymous; it may have been from gerlos not logged in, or anyone else on the Internet. gerlos: Please feel free to roll this back or edit further.) It makes another important change--it adds the -a flag. Without -a you'd be removed from all other groups (if adding you to the named group succeeded). But I don't know if netdev will work for this either; none of my Ubuntu systems (including 13.04) have either group. Jul 22 '13 at 0:36
  • 10
    I have the same problem as @DaleAmon, but this doesn't seem to fix it. Still get the same error even when I try to select an existing wireless network. Nov 23 '13 at 15:34
  • 1
    @gerlos Hey, my comment was quite short. I wrote it at work while scanning answers. I tried this on Raspbian. I installed NetworkManager and had been using it to develop with in Qt. Eventually, this problem arose when trying to run the application with different user levels. What helped for me was to add a PolicyKit rule for NetworkManager. See this answer: askubuntu.com/questions/668411/…
    – Zimano
    May 24 '18 at 15:36
  • 1
    Since there's some uncertainty, I just want to confirm that using "netdev" like in the edit above worked perfectly for me on Ubuntu Mate 20.04. Sep 4 '20 at 20:55
0

It has been a while, but I ran into this problem while updating to 14.04. In my case the problem was with the lxdm display manager. Try switching your display managers by running

sudo dpkg-reconfigure lxdm

If you don't have other manager install try something like GDM:

sudo apt-get install gdm

0

In my case, I did not have the privileges. So, either log in as root if using the GUI, or use sudo when using terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.