I have a one-day-old 12.10 install on a Dell machine with an ATI Radeon 6450 graphics card, and two Samsung monitors (one connected through VGA, one DVI). I also have disk encryption enabled, and I'm using classic GNOME instead of Unity.

This all started with a different problem, actually: when I rebooted the system, the BIOS would load, the purple background of what I assume was GRUB appeared for a few seconds, and then both screens would go into power save.

At first, I got around this by simply hard-rebooting when it got "stuck," and everything was fine. Today, I tried hitting some random keys, and surprisingly, the disk encryption screen came up. When I logged in, however, one of my monitors (the DVI) worked fine, but the other (the VGA) looked like this. (By the way, I'm using TwinView or whatever the equivalent is; that is, I'm not mirroring monitors.)

photo of monitor

The picture isn't good, but basically it's a solid color similar to whatever color the desktop background is, with lots of slightly darker vertical lines. Changing the desktop background changes this solid color. If I change to "mirror screens," this monitor displays a solid gray color.

Initially, after one reboot, I also had to deal with a different problem where I couldn't log in through X (due to ~/.Xauthority changing owners). While I was trying to fix that, I rebooted a couple times and messed a bit with my ~/.config/ (deleted monitors.xml) and /etc/X11/Xorg.conf (tried to generate a new one), and had some even weirder things happen, e.g. mirrored screens where one was translated about a quarter-screen to the left, and then wrapped.

But now that part's fixed, and I'm still left with one working monitor and one solid-color monitor.

To be honest, it might be easiest to just do a fresh install, but I'm worried the same thing might just happen again (maybe it's a hardware thing?)

EDIT: some more info--if I change to lower resolutions, that monitor starts flashing madly...


Well, I installed the new X updates from Ubuntu, and it works fine now. Not sure what was fixed, but it's fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.