I had ubuntu installed with raid 0 enabled. I have added 2 more disks went into the bios deleted and created a new raid setup using raid 10 (total of 4 disks now).

However during install of ubuntu server it asks if it should activate the RAID Sata disks, I tell it yes. Next step shows up blank for available disks when determining where to mount the root etc. Anyone have a clue as to why this would be?

2 Answers 2


My guess is that you have a fakeraid ( see http://wiki.ubuntu.com/FakeRaidHowto for background info ). Fakeraid is not supported as well as conventional software raid, so you should not use it if you don't need to dual boot with Windows. Go into the bios and delete all traces of the raid array, and when you run the Ubuntu server installer, just set up a conventional mdadm software raid.

Before you do that though, if you could file a bug report on launchpad.net against the dmraid package in ubuntu, and attach to that report the files generated by running sudo dmraid -rD, I would appreciate it. This way I may get around to fixing the problem. You can do this from the livecd.

  • Thanks for the input I will do that. I have tried to set up the software raid before unfortunately I could never get grub to properly install. Can you point me in a direction to get Grub to install on a software RAID 10, or have some sort of redundancy for the boot
    – dko
    Commented Mar 15, 2011 at 15:15
  • @dko It should "just work". Create the raid array in the installer, then choose to format it and use it for the root.
    – psusi
    Commented Mar 16, 2011 at 14:08
  • I have done that and everything will appear to install fine until GRUB, it will fail every time. I however found some more things to try and will try again later today.
    – dko
    Commented Mar 16, 2011 at 15:03
  • @dko make sure you have it set to install grub to the raid array and not /dev/sda.
    – psusi
    Commented Mar 16, 2011 at 19:35

I've noticed Disk Utility recognizes my dm-raid drives twice. For example, my RAID0 drive (two 200GB drives) shows up as dm-0 (400GB) and dm-4 (400GB). Perhaps you need to activate a different one.

One thing that sounds odd there is that term "activate". I'm not sure that the installer should need to activate a dm-raid partition (what you're trying to use); I've only noticed that with Linux-based softRAID.

Also, you might need to reboot & restart the installer. I've seen it fail many times when saving changes to partitions; after a reboot, the changes are intact and the installer recognizes them.

  • Thank you for the input however I have tried rebooting several times. I'm using the motherboards fake raid, and would like to use it as I can typically get Grub to install on it
    – dko
    Commented Mar 15, 2011 at 16:31
  • 1
    I've only used fake raid on a few systems but have never had an issue of the installer not detecting the RAID. Perhaps it's an issue between the Ubuntu installer and your RAID chipset. As for RAID10 on GRUB, I feel your pain. The workaround I use is to create a small RAID1 array for GRUB (you can add multiple spare drives) and a RAID10 array for everything else. This keeps GRUB happy and you get all the benefits of RAID10 -- as I understand, linux softraid (mdadm) will outperform fakeraid during reads. Commented Apr 30, 2011 at 11:58
  • @user9347 I've tried grub on raid 1 as well, still failed. I just hope that the boot drive isn't the one that fails if one gives out.
    – dko
    Commented May 4, 2011 at 23:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .