1

I tried installing samba from Ubuntu Software Centre and from command line after installing .

When I tried opening it is now showing in the application launcher or now working through command line. From Terminal From App Launcer

Any help

2
  • Which file did you install?
    – Mitch
    Jun 4 '13 at 5:41
  • 1
    samba doesn't work that way.. Try if it's running using smbstatus.. It probably won't give you much because you haven't configured it yet. smbd --version will print te current version of your install
    – Bart.a
    Jun 4 '13 at 6:16
2

I had the same problem. Here is the solution that worked for me.

NOTE: If you have tried the installation and it doesn't uninstall Samba, Samba-common, system-config-samba first. to do it just replace "install" with "remove" in steps 3 & 4

Open Terminal

  1. Install gksu:

    sudo apt-get install gksu
    
  2. In the terminal, run

    gksu-properties
    

    In the dialogue that follows set authentication mode to "sudo" and grab mode to "enable".

  3. Install Samba:

    sudo apt-get install samba samba-common
    
  4. Install Samba Config:

    sudo apt-get install samba system-config-samba cifs-utils
    

The Samba icon showed up on the launch bar and everything worked fine.

I take no credit for this solution this answer is form "user168736" answer here

1

As Bart.a points out, samba doesn't work that way. The package called samba|samba4 just provide the modules and tools to allow applications connect trough the CIFS protocol to NetBIOS implementations. But, lets quote the Wikipedia article:

Samba is a free software re-implementation of the SMB/CIFS networking protocol, originally developed by Andrew Tridgell. As of version 3, Samba provides file and print services for various Microsoft Windows clients and can integrate with a Windows Server domain, either as a Primary Domain Controller (PDC) or as a domain member. It can also be part of an Active Directory domain.

Meaning, samba isn't an application with a GUI, but a module/service to *nix systems.

The samba client is mostly manageable with the defaults file browsers (Nautilus, Konqueror, etc...), with little or none configuration. To check all the SMB/CIFS resources available in your network, just typing network:// normally should show the results. For sharing files/devices/resources you need the samba-server, which is too configurable using the tools provided by Gnome, KDE, Unity without problems.

There are plenty of tools that allows you to browse your resources, graphically control your samba client/server here, some of them already mentioned.

0

I think you did not install all the packages you need. I think you can use the command-line version, but you're looking for the GUI one, right? Please try the following. Found that here

Install samba:

sudo apt-get install samba samba-common

Install dependencies for the tools:

sudo apt-get install python-glade2

Install the GUI samba tools:

sudo apt-get install system-config-samba

Add a samba user:

adduser yourname

Specify a user password:

passwd yourname

Now you can look up the samba tool in unity and start configuring your shares. In the link you can also find a description on how to make shares.

Good luck. And if you can't get it to work, come back here to the forum.

2
  • I did the same . Please go though my question first Jun 5 '13 at 5:22
  • maybe there is another problem. When you have installed all of the above and it still doesn't work. Try this in the terminal: sudo apt-get install gksu - then run: gksu-properties - a pop-up should appear and set authentication mode to "sudo" and grab mode to "enable"
    – Bart.a
    Jun 5 '13 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.