43

I've tried to install Ubuntu on a VMWare Virtual Machine, but it never gets past the bootloader :

ISOLINUX 4.01 debian-20100714 ETCD Copyright (C) 1994-2010 H. Peter Anvin et al
No DEFAULT or UI configuration directive found!
boot: _

I've also tried to burn this .iso image to a CD and go from therem but I got the same problem.

Some more details :

  • VMWare Server 2.0.2 Build 203138 on Windows 2008 R2
  • ubuntu-10.10-desktop-i386.iso image used (downloaded yesterday evening)
  • Remark : The 10.04 LTS .iso boots like a charm - so that issue seems to be related to 10.10 ... – user12378 Mar 14 '11 at 19:32
  • Have you tried downloading the ISO again? Perhaps you have a corrupt ISO – Reuben Swartz Mar 14 '11 at 23:17
  • Hello Reuben, yes - I've downloaded it again after my first tries failed. Same result !!! I've also downloaded the 10.04 LTS version and the Server version - both can be installed without a problem ... – user12378 Mar 15 '11 at 0:33
  • I'm having this problem too but only on the amd64 version. The 32-bit version works fine. – Cogwheel Apr 9 '11 at 19:01
32

If you are able to use a USB stick as installation media, then rename the following:

  • isolinux --> syslinux (this is a folder)
  • isolinux.bin --> syslinux.bin
  • isolinux.cfg --> syslinux.cfg

This worked for me.

Original source: 1, 2

  • I'm not sure how USB flash drives are relevant to the question... – Cogwheel Apr 9 '11 at 18:58
  • My iso already have an 'syslinux.cfg'. Do I replace it with 'isolinux.cfg'? – kbtz Jul 31 '12 at 0:29
  • 1
    Same as cvsguimaraes for me. Folder was already called 'syslinux' and there is already a 'syslinux.cfg' present, but there's no 'bin' file for either. I tried making a Live USB using Lili and 12.10 64-bit. – Erlend Dec 7 '12 at 3:34
  • Got this same error trying to install beta Ubuntu Studio 13.10 to a physical machine. This fixed it! +1, Thanks. – Paul Oct 12 '13 at 4:11
  • use isomaster or furiusisomount to edit .iso file – Kokizzu Aug 22 '14 at 6:13
14

Two suggestions:

Suggestion 1:

If you are using a USB stick, make sure it is formatted as FAT16 (or just FAT), not as FAT32.

Suggestion 2:

Try entering mboot.c32 -c boot.cfg at the "boot:" prompt.

(Source)

0

I wrote the Ubuntu image to a USB flash drive using Startup Disk Creator and had the same error during booting it.

Launching Partition Manager I saw that the partition is FAT32. I recalled that I didn't format the partition during image writing -- it already was FAT32 (perhaps from previous Windows installation).

So I deleted the partition using Parition Manager and rewrote the image (Parition Manager showed that the created partition is FAT32 too). It booted fine. I guess something was wrong with the format of the partition.

0

If you're using YUMI with USB memory stick there are certain Ubuntu versions which ISOs are not added correctly - for example, 16.04.5 LTS versions is added OK but version 16.04.6 LTS ISO image results in the "No DEFAULT or UI configuration directive found!" error