6

When I mount my encrypted .Private data, I can access (rw) my data fine. After a while the mount seems to be unmounted automatically. Is there a default timeout? If so, how can I change it? The timeout appears to be fairly short (order of a few minutes) and seems to occur when I try to access the share remotely using rsync (i.e. via ssh).

I didn't find anything when searching for 'time' in the man pages of ecryptfs-mount-private, ecryptfs-setup-private, ecryptfs or ecryptfsd.

1
2

There is no timeout. I had the same problem and according to David's comment above I commented out pam_ecryptfs from /etc/pam.d/common-auth, /etc/pam.d/common-password, /etc/pam.d/common-session and /etc/pam.d/common-session-noninteractive and it stopped unmounting.

Actually cron should only be running the last one, but if you don't actually have the same password for your account and the private data (I don't), it's better to remove it from all of them, because additional login, e.g. on console, would also unmount the share.

0

I use the solution from Jan Hudec's, but modifying the files directly causes warnings during the update process, and they are possibly not updated when necessary.

An alternative to the manual modification is to use sudo pam-auth-update --force. In the interactive dialog, you will find an option to disable the integration with ecryptfs, as can be see for instance in the following question: How do I change options in PAM configuration?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.