1

I have Ubuntu 13.04 64 bit x86 on my laptop and I am trying to make it possible to wake up using my wireless keyboard, thus I need to enable wake up on USB. I have read several guides but it simply does not work. I need to enable USBX below. Please make the guide very easy to follow. Thanks! When I use windows I can wake the computer from sleep using the same keyboard.

Look below in the list on the USB there are no PCI connected and on these items that do not have a PCI listed I cannot change disable to enable. i.e I manged to change disable to enable by using the command sudo sh -c "echo RP04 > /proc/acpi/wakeup for the RP04 device and this is possible because there is a PCI listed on this device. So how do I add a PCI to the USB devices is this possible due to hardware??? If I purchase a USB card will this have a PCI listed on it?? I am guessing that the USB are connected directly to the mother board.

Thanks!

P0P1 S4 *disabled
PEG0 S4 *disabled
PEG1 S4 *disabled
PEG2 S4 *disabled
PEG3 S4 *disabled
XHC1 S3 *enabled pci:0000:00:14.0
EHC1 S3 *enabled pci:0000:00:1d.0
USB1 S3 *disabled
USB2 S3 *disabled
USB3 S3 *disabled
USB4 S3 *disabled
EHC2 S3 *enabled pci:0000:00:1a.0
USB5 S3 *disabled
USB6 S3 *disabled
USB7 S3 *disabled
HDEF S4 *enabled pci:0000:00:1b.0
RP05 S4 *disabled
RP06 S4 *disabled
RP07 S4 *disabled
RP08 S4 *disabled
WLAN S3 *enabled pci:0000:02:00.0
RP03 S4 *disabled
XHCI S3 *disabled
RP04 S4 *enabled pci:0000:00:1c.3
GLAN S4 *enabled pci:0000:03:00.2
XHC S4 *disabled
SLPB S4 *disabled 
0

Make sure that wake on USB is active in your BIOS settings. You can easily enable wake for USB devices with these handy scripts (it creates the u-dev scripts for you): http://bernaerts.dyndns.org/linux/74-ubuntu/220-ubuntu-resume-usb-hid

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.