1

I am having a problem with the fan speed with my new Dell Inspiron 5521 i7-3317U, Full HD with installed Ubuntu 12.04. The fan is too noisy.

After starting the Laptop, the fan starts and is not stopping or changing the revolutions at all. Still I didn't install any Windows just because the Laptop is new. What should I do: return the Laptop or will updating the BIOS will solve the Problem? I saw that there is a newer version of the BIOS: AO7.

1
  • You also need to update the bios ...Download Ubuntu 13.04 x64, Make a boot usb, Use live session & check with it ....
    – Qasim
    Jun 15, 2013 at 15:38

2 Answers 2

4

I suggest you to use i8kutils, a collection of utilities for Dell laptops. In this collection there is i8kmon, which is the utility I'm actually using right now.

How To solve Dell laptops fan issues in Ubuntu

  1. First of all, let's download and install i8kutils. Open your terminal and write:

    sudo apt-get install i8kutils

  2. Now you've got to add i8k to your modules. Open the modules file:

    sudo gedit /etc/modules

    and add the string "i8k" (without quotes) to the file. Save and exit.

  3. Create an i8k.conf file

    sudo vim /etc/modprobe.d/i8k.conf

    and fill it with this code:

    options i8k force=1

    Note: Some older guides will tell you to create a /modprobe.d/options file. The "options" file isn't used anymore on Ubuntu. What does matter is that you create a file with a .conf extension (the filename isn't important, but I decided to name it i8k.conf for clarity). So beware of older i8kmon configuration guides.

  4. Now restart your computer, or run this code to make i8k run:

    sudo modprobe i8k force=1

  5. We will now create a i8kmon.conf file which will tell the i8kmon utility how to behave.

    sudo gedit /etc/i8kmon.conf

    Paste the following code in it:

    # Run as daemon, override with --daemon option
    set config(daemon)      0
    
    # Automatic fan control, override with --auto option
    set config(auto)        1
    
    # Report status on stdout, override with --verbose option
    set config(verbose) 1
    
    # Status check timeout (seconds), override with --timeout option
    set config(timeout) 20
    
    # Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
    set config(0)   {{-1 0}  -1  40  -1  40}
    set config(1)   {{-1 1}  30  60  30  60}
    set config(2)   {{-1 2}  53  128  53  128}
    
    # For computer with 2 fans, use a variant of this instead:
    # Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
    # set config(0) {{-1 0}  -1  52  -1  65}
    # set config(1) {{-1 1}  41  66  55  75}
    # set config(2) {{-1 1}  55  80  65  85}
    # set config(3) {{-1 2}  70 128  75 128}
    
    # end of file
    

    This has been edited to match my Dell Inspiron 15r 5521 fan configuration (and I hope I did it well). If you want more informations take a look at the documentation on Ubuntu Manuals: http://manpages.ubuntu.com/manpages/gutsy/man1/i8kmon.1.html

  6. Now you should be able to run i8kmon from your terminal and see if (and how) it's working. Simply run:

    i8kmon

Finished!


Sources:

1
  • Make sure that you really place the configuration file at /etc/i8kmon.conf instead of /etc/default/i8kmon which the i8kmon man page suggests. See my answer to askubuntu.com/questions/717067/…
    – loop
    Apr 24, 2016 at 12:44
0

Try to enable powersaving for chipset and other devices:

sudo apt-get install powertop

sudo powertop

Go to "tunables" tab and change all "bad" items to "good"

All changes reset after reboot. And some of them change depending on AC/Battery mode.

So you also have to make powertop changes permanent and disable pm-powersave scripts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.