0

I want to install NS2 in Ubuntu.

I run the below command:

sudo apt-get install build-essential autoconf automake libxmu-dev gcc-4.3 

But I got an error:

Package gcc-4.3 is not available
.
.
.
E: Package 'gcc-4.3' has no installation candidate.

Could you please provide me how to install gcc-4.3 [Step-by-Step]??

  • Try with gcc-4.4 – Leo Jun 2 '13 at 15:06
1

Install the metapackage gcc. This will automatically install the latest available version of gcc, so you won't need to worry about the details. If you need an outdated version for this particular program to build, gcc-4.4 is the oldest you can get through the package manager.

To clarify, that's sudo apt-get install gcc or sudo apt-get install gcc-4.4

I'm not aware of any archives that have the particular 4.3 release that you're looking for. I am assuming that any version will work just as well, and that NS2 merely provided old build instructions.

  • down vote accept Thanks for your support.I run that command and get the below message: gcc is already the newest version. actually I am trying to install NS2 by following up the steps of below article: whackk.com/april-2011/how-installing-ns-234-ubuntu-1010?page=1 But, when I apply step#5 I got a message: Package gcc-4.3 is not available . . . E: Package 'gcc-4.3' has no installation candidate. How I can solve this error? – Tariq Jun 3 '13 at 17:22
  • I still think the latest version would work, but I decided to try answering your actual question and I discovered this website which provides old GCC versions: gcc-uk.internet.bs/releases I downloaded one, and it had HTML installation instructions in it. – Wutaz Jun 3 '13 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.