1

First off, I am new to Linux/Ubuntu, and I barely know anything about it. I know this was answered on the web many times, but I tried all I could find, and nothing worked. There is no way I could access internet inside Ubuntu, as wi-fi is my only source of connection. I am dual-booting it on a MacBook Pro Retina (mid 2012), if that's any useful information... Another thing is that when I open System Settings>Software & Updates, and enable "Cdrom with Ubuntu 13.04 'Raring Ringtail'", and open the additional drivers tab, I see "Broadcom Corporation: BCM4331 802.11a/b/g/n", and below it says "This device is not working.". If I enable it, it just reverts back to "Do not use this device".

I have also tried the n43 solution, and a whole bunch of terminal commands that I found on the web, to get it working. I had no luck so far. I'll put additional information if I need to.

Thank you for your time.

0

long time since I had this kind of problem. YOu can get it propably running by ndiswrapper but first you need to kill any module accesing it post here your lsmod

rough idea is to kill not working module, find ini file and some libs from your driver copy it into your home directory from USB key

ndiswrapper -i <your inifile from windows driver of the same architecture as distro>
sudo modprobe -r <your not working wifi driver>
sudo modprobe ndiswrapper

but after you disable card and then you may need to kill module so send outcome of

lsmod
9
  • The output is too long, but I found this site and posted it here. – Luka Kotar Jun 1 '13 at 21:50
  • Which means you need to do sudo modprobe -r b43 before modprobing ndiswrapper – Tomas Jun 2 '13 at 0:04
  • Okay, thanks. Where do I find the ini file and the libs? I'm not sure where to look for them. – Luka Kotar Jun 2 '13 at 1:28
  • if you look at the driver cd for your wifi, check the winXP folder. it maybe inf too for example bc.inf or download and unpack winXP driver if you are using 64bit distro, driver has to be64bit too – Tomas Jun 2 '13 at 1:55
  • After executing the first command, it tells me that 'ndiswrapper' is not currently installed, and that I can install it using sudo apt-get install ndiswrapper-common. I try it, and it couldn't locate the package. Assuming that's because of no Internet access. – Luka Kotar Jun 2 '13 at 15:22
0

This is probably a long shot but, is there :

  • a physical button on your laptop which is used to turn the wifi on / off ?
  • a combination of keys on your keyboard that can be used to turn the wifi on / off ?

I don't know much about Apple products unfortunately.

You could also try booting Ubuntu from a CD / USB again, see if the Wifi works in "try ubuntu" mode. Perhaps one of the changes you made since install has disabled the wifi card.

1
  • There is neither a button or a key combo to turn the wifi on/off. Wifi didn't work inside "try ubuntu" either. I have freshly re-installed the OS now, which didn't seem to change anything. – Luka Kotar Jun 2 '13 at 1:34
0

Thank you all for your help. I've been able to fix the issue by connecting to the internet using a wireless USB I had borrowed from a friend, then installing "Additional Drivers" from the "Ubuntu Software Center", and enabling the Broadcom STA wireless driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.