I upgraded from 11.10 to 12.04, now when I try to run Firefox from the icon it pops up this: "Missing Profile. Your Firefox profile cannot be loaded. It may be missed or inaccessible." I already tried to remove Firefox and re-installing it. And the command

sudo chown -R $USER:$USER ~/.mozilla

I've also tried to delete the profile file, or renaming it. I've found some solved problems but they didn't work for me. Maybe I should mention that if I run Firefox from terminal using sudo it starts fine.

Any idea about how could I solve this?

  • Well, I've solved it by the moment. I realize that before I upgraded, Firefox was in the version 20.0.1; after upgrading, Firefox is v21.0.0. I've read that Firefox v21 wasn't stable in Linux yet. And maybe that was the trouble, so I downloaded the version 20.0.1 and (I don't know exactly how to install it) ran the file 'firefox-bin' after uninstall the other version and delete de .mozilla folder. It worked! But now Firefox doesn't have is characteristic icon! Can someone tell me to wich folder should I move the Firefox folder (I mean the one that comes in the .tar file)? – Luis J. Romero Jun 1 '13 at 19:23
  • I had the same issue and I did: sudo chown -R $USER ~/ – Lilian A. Moraru Apr 19 '16 at 7:36
  • How about running sudo firefox? – peter Oct 6 '17 at 20:43

12 Answers 12


I got the same case, and I tried to change permission of mozilla cache and it worked:

root mode

sudo -s
chown -hR $USER:$USER ~/.cache/mozilla

but after I changed, there's pop-up suggested me when I opened firefox to create a new profile. I just want to use an older profile. So I changed the permission of old profile too into my user!

chown $USER:$USER ~/.mozilla/firefox/profiles.ini

dont forget to make a sure the file permission is changed :)

  • Thanks, I will try it, thought, I solved it with the first answer of this question: askubuntu.com/questions/303228/… I realize that the problem is with Firefox 21. I installed an old version (20.0.1) and it worked. Maybe now I can update to FF 21 and try what you say. – Luis J. Romero Jun 5 '13 at 2:45
  • @LuisJ.Romero: If this answer did help, just click the little grey under the "0" now turning it into beautiful green. If you do not like the answer, click on the little grey down-arrow below the 0, and if you really like the answer, click on the little grey ☑ and the little up-arrow... – Fabby Oct 27 '15 at 20:31
  • You can also run it as root to run lsof for firefox's pid. That will give you an indication of what files firefox tries to open – peter Oct 6 '17 at 20:42

Removed profile file, changed permissions of profile folder, etc. None of them worked. Finally, changing ownership recursively on ~/.cache worked :

sudo chown -R $USER:$USER ~/.cache/

After all other solution this little line saved my day:

sudo chmod -R 777 .mozilla/
  • Mine too and is working. Thx – CARTOS Nov 9 '17 at 13:44

Try deleting the current profile. That will force Firefox to create a new profile. Profile folders are located here:

~/.mozilla/firefox/<profile folder> 

The .mozilla folder is a hidden folder. Make sure that you check show hidden files in your file manager (Browser).


Had a similar issue. Had to delete the profiles.ini file in ~/.mozilla/firefox/. Tried all kinds of permissions solutions to no avail. Once profiles.ini was deleted, firefox created a new profile.

  • I had the same case – Viesturs Mar 26 '18 at 14:27

I just encountered this in 14.04 after an attempt to move files from my previous install failed. I am no expert, but this worked: Edited profiles.ini file in ~/.mozilla/firefox/ commented out (using ; below)


Created a new path line so that the hash matched the [this.is.a.hash].default folder name in ~/.mozilla/firefox/

Maybe I could have renamed the folder to match the name in profiles.ini, but easier to trace back the problem knowing I could delete the new and uncomment the old Path= from within profiles.ini.

Fortunately for me, I installed 14.04 on a new SSD and kept the old 12.x release. Now I'll try what I should have done in the first place - a proper Firefox profile backup/move from the old installation.


Copy your profile-folder to /home/USERNAME/.mozilla/firefox and run firefox -Profilemanager or firefox -P in terminal, create new profile and select your old profile's folder. Starting the Profile Manager

  • Only one that worked for me... last on the list! – Tom Jul 16 '18 at 16:38

Following steps worked for me.

1.Kill all currently running process

killall firefox
killall thunderbird

2.Remove the cache Files

Note: Backup them before removing.

$ rm -rf ~/.mozilla/
$ rm -rf ~/.cache/mozilla/

3.Change the ownership of following folders

$ sudo chown -R $USER ~/.cache/.mozilla/
$ sudo chown -R $USER ~/.mozilla/

** if the above step NOT successful, Then try following **

$ sudo chown -R $USER:$USER ~/.cache/.mozilla/
$ sudo chown -R $USER:$USER ~/.mozilla/

** if the above step NOT successful, Then try following **

$ sudo chmod -R 777 ~/.cache/.mozilla/
$ sudo chmod -R 777 ~/.mozilla/

4.If all above steps NOT successful, Then change entire cache folder permission

$ sudo chown -R $USER ~/.cache
$ sudo chown -R $USER:$USER ~/.cache
$ sudo chmod -R 777 ~/.cache/

None of the answers worked for me (Ubuntu 18.04, Firefox 66 and Firefox Dev). After uninstalling Firefox (sudo apt remove firefox), deleting the cache (rm-rf ~/.cache) and reinstalling (sudo apt install firefox), both Firefox and Firefox Dev started working again.


If you linked your ~/.cache directory to an external drive (something similar to this guide on how to run Firefox off your RAM), try removing your existing link and creating again that directory.

I just ran into this error because a few months earlier I went into a hacking fit in a VM and linked that folder into an USB drive to cut down on HDD activity, and then I migrated my VM to another host computer and removed the drive where that folder was located, and now that the link was broken Firefox wouldn't start and gave me this error message. I recreated this directory, and now Firefox starts fine.


Your firefox user profile is missing or corrupted probably.

Run firefox from a terminal with the ProfileManager option:

firefox -ProfileManager

It should open up a dialog box allowing you to create/delete profile. What I did was just delete the offending profile in the dialog and created a new one and it worked.

If you have valuable data in your profile you may want to back up the profile folder located at:


I didn't back mine up because I didn't need it, but just throwing it out there in case somebody does.


I tried to follow the instructions above, and found that my ~/.cache is a file, not a directory.

I deleted it and re-tried to start Firefox.
Then no error info popup occurred. Quite strange.

Not the answer you're looking for? Browse other questions tagged or ask your own question.