I just performed a fresh install of Ubuntu 12.04.2 LTS without any issues. I updated the software, I installed the recommended proprietary drivers, installed any additional software that I wanted with no problems.

However, I can't seem to change any system settings, they don't stick. I can access system settings, I can click on each option, but when I select an option to change it doesn't take.

For example if I click on Time and Date Settings and place a checkmark beside show weekday and date and month. It will place a checkmark beside those options but won't actually change in the menu. When I press the "X" to close out and go back into settings it's back to the default and the options I checked are unchecked.

Also happens with wallpaper, I can see all my wallpaper, but I select another wallpaper other than the default and it won't change. I turn on auto hide launcher and it doesn't auto hide. I change my shortcuts on the unity bar and when I restart my computer the settings don't stick they go back to the defaults.

Any idea what I can do to fix this or why it is happening. Other than that everything is working.

Edit, when I log out of my user account and into a guest session, I am able to adjust all system settings without issue.


2 Answers 2


I don't know if you eventually solved your problem, but I had the same problem after 'upgrading' to 13.04, and then downgrading back to 12.04.

What worked for me, was to go into my home directory and remove all of my dot file and dot directories. I didn't test carefully for which one made it work, but do


ls -a

.this .that .somethin .somethinelse


One of those is some how corrupted or unwriteable or something, and can't persist your changes. Depending on your knowledge and confidence, delete all the ones you don't care about, or delete them one-by-one until you find what works, or google each one before deleting it.

rm -rf .this

rm -rf .that


  • Deleting the files stored hidden /home/user/ directories removes settings, caches, configs and more; if you proceed with these tasks you run the risk of losing a lot of personal system settings and more. Compiz settings are stored in .compiz and, if these settings or other like it, are required for your computer to function as it does, do not delete these. You will have no startup programs if you delete /home/user/.config/ and other items may be broken. Jul 8, 2013 at 15:24
  • 1
    Yes, but it seems to me like that kinda comes with the territory of reinstalling an operating system; getting rid of the cruft and getting a fresh start. Create a new user account and (before logging into that acct) take a look at how many (how few) dot-files/dot-directories are in the brand-new home directory. Those are the most essential ones. The rest are simply means to remember settings and personalizations and configurations, etc. Depending on how important those are to you, be careful when you remove things. If you want to just clean house and get a fresh start, then be less cautious.
    – RubeRad
    Jul 8, 2013 at 17:07
  • 1
    +1, this actually worked. I had the same issue with 14.04, but rm -r .cache .config .compiz fixed it; I think these files got corrupted due to a forced restart. Deleting them gives a fresh start, and now the settings, wallpaper etc. work again. Nov 25, 2014 at 6:24
  • Worked on a fresh 16.10 Ubuntu-Gnome install having the same problem.
    – robsn
    Dec 7, 2016 at 10:33

I had the same issue after changing permission of my complete Home folder (sudo chmod -R 700 /home/user1) on Ubuntu 14.04.2. For some reason the problem only appeared for user1, but not for the second user (user2), although I changed permission for all user the same way. Besides I had a forced restart after this Permission-change, so maybe this was the reason for my problem.

After reading this thread I just restored the old permissions for /home/user1/.cache, .config and .compiz (sudo chmod -R 755 /home/user1/.c?). I started with .config, which restored my system settings but not my wallpaper. After doing the same to .compiz my wallpaper came back. At last I did the same with .cache, just to be sure.

I will try a restart and a change to the "new" permissions (700), just to see, if it really depends on the permissions of these folders.


I restated my computer with 755 permission and it kept all system settings. Then I changed back to 700 for complete /home folder, reboot again and still all settings are there.

I don't know what exactly the problem was, but maybe for some others experiencing this problem it would help to change permissions of the three folders to get back access to there settings instead of deleting them, too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .