I am using Ubuntu 12.04 on a Lenovo e430 laptop. For the next month I am going to stay in a flat with no internet connection, so I want to use Huawei e173 modem to connect. ( And share the connection through wireless )

I downloaded the glorified Mobile Partner for Linux. It seems to work for everyone. But for me, when I plug the modem in, nothing happens. ( The green light blinks and its contents are shown like a flash drive but that's all. ) When I run the Mobile partner from Dash, nothing happens. When I run the file manually, nothing happens and when I "run it in terminal", the terminal window immediately closes and nothing happens. And I have no idea what to do.

lsusbs says:

Bus 003 Device 007: ID 12d1:1c0b Huawei Technologies Co., Ltd.

UPDATE: The mobile partner that did not run was version 11.something and I installed 21.something - it does run, but it is in Spanish and only for the provider Movistar. So it is of no use for me.


Try using bam mobile partner happened to me when I used mobile partner. http://namakutux.blogspot.com/2012/07/bam-huawei-mobile-partner-for-linux.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.