I'm trying to set it up such that after I open Pidgin, the application opens without showing an icon in the unity launcher.

Because Pidgin already has a way to open the window through the top-bar, I don't want the pidgin icon wasting space on the launcher, even after it's open.

I tried modifying the .desktop file as explained in this question, adding this line to my .desktop file:


By this the application will only be shown in GNOME, XFCE, or KDE but not in Unity.

However it doesn't seem to have any effect. Is it because Pidgin is a special application that also launches through the top-bar or something? I was able to change the icon and other things, but I can't keep it from appearing on the side launcher.

Thanks in advance.


Launcher is a bit of a misnomer for the bar on the left in Unity. Any running application with an open window, will show on the launcher, regardless of what the .desktop file says.

  • So there is no way around this? Based on answers from other questions, it seems that at least some people think it's possible to change, though I haven't been able to figure out how. (For example, there are some small utility applications that don't show up on the launcher, but instead show up on the top tool-bar. Is there a way for me to replicate this behavior with someone else's application?) Thanks! – NHDaly Jun 3 '13 at 14:20
  • Does that application have an actual main window? Or is it's entire method of interaction via the indicator it puts in the top bar? – dobey Jun 3 '13 at 15:38
  • Ah, I see. It does have a main window. And, in fact, when I open the preferences pane on the other utility apps, they also show up in the launcher when they open a window. So the issue is that Ubuntu needs to put an icon on the launcher for every window? – NHDaly Jun 3 '13 at 20:10
  • Yes, that is how it is designed to work. As I said, "launcher" is a misnomer, as it's also the "taskbar" where you switch between running apps, with open or minimized windows. – dobey Jun 3 '13 at 20:13
  • Okay, thanks. I came from Mac where the dock serves this same purpose, but by modifying the App bundle you can turn off "show icon in dock". But it sounds like you can't do this with Ubuntu? Thanks! – NHDaly Jun 3 '13 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.