This is not just gnome terminal, but pretty much all gnome windows: When you hold the "alt" key, you can press the first letter of one of the menu items. This will let you scroll that menu without clicking on it directly.

This is okay on any other window, like say Firefox, but on gnome terminal, it steals the keys I use for emacs!! There is very little chance of me learning a new set key combinations if I can avoid.

If I can't isolate this just to gnome terminal, I'm fine with that.

  • 5
    Seems worth a bug report. It's a terrible idea for a terminal emulator to intercept Alt or Ctrl combinations. – ak2 Mar 13 '11 at 21:24
  • This behavior might be useful if it didn't negatively impact my ability to use the terminal. – taranaki Jul 11 '16 at 17:56
up vote 53 down vote accepted

Edit > Keyboard Shortcuts..., and uncheck "Enable menu access keys".

  • 2
    This doesn't seem to work for me (natty, unity interface). ALT will still bring the menu up. – Johann Philipp Strathausen Jun 1 '11 at 16:06
  • 2
    Works in Oneiric. – Emil Sit Nov 19 '11 at 3:43
  • 4
    Works on Ubuntu 14.04. – David Boshton Jan 9 '15 at 9:05
  • 2
    I use Ubuntu 15.10 and in the Edit menu of GNOME Terminal there is no option "Keyboard Shortcuts", just "Preferences" and "Profile preferences". Can somebody guide me to the location of this setting in my version of GNOME Terminal? Thank you! – silviubogan Nov 29 '15 at 14:52
  • 2
    Is there a way to do this in 16.04? – Hatshepsut Sep 6 '16 at 23:52

For Gnome terminal 3.14.1: Click Edit (on menu bar) > Preferences > At last on "General" tab, Un-check "enable mnemonics..." .

  • This worked for me, thanks. Alt-C and Alt-V are now map-able. Woo hoo! – Gray Feb 15 at 20:05

This is really driving me crazy too. I'd like to use Alt-V for paste as it is much more ergonomic than using CTRL but this doesn't seem possible because of the View menu option.

Overall this seems like a bug because when I disable the hotkeys in Preferences I am no longer able to use Alt-V for accessing the View menu but I am also not able to use that combination for other things.

I was able to get Alt-Z to work because there is no menu beginning with Z.

  • In gnome-terminal version 3.14.3, they've added a "Enable mnemonics..." preferences entry that you can disable. Then the Alt-V is map-able. Oh glorious Alt-C / Alt-V. – Gray Feb 15 at 20:02

If you want to do it globally, you can try this method (source):

To disable mnemonics you should create (if it doesn't already exist) ~/.gtkrc-2.0. This file should contain the line gtk-enable-mnemonics = 0 (you can add other GTK settings if you'd like). Then, restart for the changes to take effect (you may be able to log out then log in instead).

The alt key will still make menus appear in some cases, but the mnemonics are now disabled. Hoorah!

EDIT: this method no longer works. I filed a bug report regarding the OP's question so we'll see how it evolves.

  • 1
    I tried it today on ubuntu 14.04 and it worked :-) – gwenzek Mar 4 '15 at 9:54

In Ubuntu 16.04, go to System Settings -> Keyboard -> Shortcuts -> Launchers, and clear the Key to show the HUD (or change it to another key)

  • This is my preferred option -- to disable the HUD entirely -- because a) the HUD is thoroughly useless, and b) if I accidentally press Alt by itself whilst using Bash Alt+F Alt+B shortcuts, the HUD irritatingly steals focus away from the terminal. – Damien Ó Ceallaigh Oct 19 '16 at 0:46

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.