I have a new USB drive which came with a single NTFS partition.

How can I shrink that so that I can create an ext4 partition?

gparted does not seem to have the "Resize" option highlighted.


After following the directions below, after unmounting I am still not able to resize the partition. There is a warning though:

Unable to find mount point. Unable to read the contents of this file system! Because of this, some operations may be unavailable. The following list of software packages is required for ntfs file system support: ntfsprogs".

However, with the partition mounted, I can read & write to the file system on the drive just fine, and ntfsprogs is installed and current.

What's next?

  • @ chris - lets get back to basics, are you trying to resize the partition using Gparted via live CD or by Disc Utility in Ubuntu? Mar 15, 2011 at 12:25
  • Ubuntu 10.10, from System -> Administration -> Gparted partition editor. I just checked with another drive, and it has the same problem - there's something that's not allowing NTFS volumes to be resized. And I know I changed the partition size on that drive with gparted, so perhaps there's a bug in the newest release?
    – chris
    Mar 15, 2011 at 21:15
  • I'd recommend you try using Gparted from a Live CD rather than from within the OS. For whatever reason my Ubuntu installed version of Gparted will not let me unmount my Seagate Freeagent drive (has key synbol next to drive) but from a Live CD it works fine. You can download Gparted from sourceforge and burn to CD or use a Live CD/USB of any Ubuntu install to do what you want. Mar 17, 2011 at 10:25
  • try the Live CD environment and let me know if your able to achieve what you want. Mar 19, 2011 at 1:25
  • That did it - though I'm sure that last time I did it, I didn't have to use the live CD. But thanks.
    – chris
    Mar 19, 2011 at 12:34

8 Answers 8


You will not be able to resize the drive while it is mounted ie: in use - boot into Gparted Live CD, attach the drive (make sure it is not mounted!!) and then you should be able to resize the drive as you want.

Here is some useful documentation on using Gparted: http://www.dedoimedo.com/computers/gparted.html

enter image description here


Using gparted, you should start by right-clicking and choosing "Unmount". This will allow you to edit the partition.

You should then be able to use the resize command as well as be able to make new partitions on the USB drive, and should allow you to create an ext4 partition alongside the NTFS partition.

  • 1
    I agree, I should be able to do that. The problem is that I can't :)
    – chris
    Mar 17, 2011 at 20:34
  • You need to do it via a LiveUSB. Otherwise, it won't let you unmount because its an active partition
    – Thomas Ward
    Mar 17, 2011 at 21:04
  • no need to boot from a live CD to unmount
    – Takkat
    Mar 18, 2011 at 21:53

Unmounting an external USB drive for partitioning

From a running Ubuntu (no need to boot from a live CD) you need to unmount the external USB drive using a terminal with the following command:

sudo umount "/media/External USB"

Mind that the mountpoint "/media/External USB" is different on your system and depends of the name you gave your drive. If you are not sure the mountpoint of your external drive is shown in System -> Administration -> Disk Utility, or with the command mount -l in a terminal.

GParted or Nautilus will not let you unmount the drive without removing the USB drive as well.

Once the drive is unmounted you can resize or reformat your partitions with GParted or any other partitioning tool.


You'll need to unmount it first, probably best achieved through Nautilus, and then you can open GParted and resize the partition.

  • When you unmount the drive through nautilus it no longer shows up on Disk Utility or Gparted - using a live cd you see all attached drives...... Mar 19, 2011 at 1:23
  • A little late, but for future visitors -- Nautilus will "eject" the drive, not unmount it. You can instead run umount /dev/sdX1 from the terminal, or open the Disks utility, highlight the correct drive, and click the Stop button to unmount the partition without ejecting the entire device. Jul 14, 2017 at 20:57

Here's my experience...your mileage may vary.

I had an external USB HD, primarily used for massive backups. But when I plugged it in, two logical drives appeared: this annoyed me. They were formatted ntfs.

When I ran Gparted from the Ubuntu menu, I could click on "Unmount," but it wouldn't do it. Forget all the "whys"...bottom line: Gparted would not unmount the partition...which meant I couldn't reformat, resize, etc. So...

From a terminal I ran mount -l and saw that the drive was mounted at /dev/sdc1

From the terminal I typed sudo umount /dev/sdc1

After this, I could use the Gparted utility from the Ubuntu menu to delete the partition, reformat etc.

For the record, I tried unmounting with Nautilus: didn't work. Then the drive didn't show up on Gparted at all!

Hope this helps/works for you.


run chkdsk /f on windows before resizing in ubuntu. If there are unresolved errors on the filesystem, resize option does not work.


I disagree with the comments that you need to perform this operation on a Live CD. You're talking about an external USB drive, not a system drive. You definitely can do this operation from your installed system.

If gparted is reporting this error, you might have something wrong with the ntfs partition. You should probably run sudo ntfsresize --info /dev/sdX1 on your partition. This tool (it's used by gparted itself to do the resize) will report if there's something wrong with your ntfs partition that should be fixed with chkdsk /f on Windows.


Or you can use gnome-disk-utility found in Administration > Disk Utility. It will list your usb in storage device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .