I'm facing a weird problem. My mouse automatically focuses on menu items.

I'm unable to navigate menus with keyboard if the cursor rests on a menu item as it keeps stealing focus. I can live with this behaviour in regular apps but it won't let me play any full-screen games as the cursor remains locked in a fixed position.

I tried turning off compiz and removing all the dotfiles but it didn't help.

Here is a video my mouse stealing focus: http://dl.dropbox.com/u/275756/mouse.ogv

  • How strange. If I try simulate that behavior it doesn't even behave like in your video. I need to move the cursor over the next menu item before it steals the focus. Something is definitely messing with your cursor focus. – invert Aug 25 '10 at 14:29
  • Interesting issue, and I can reproduce this (well, in Firefox it doesn't happen, but in Gtk & Qt applications it does, and in OOo the selection disappears instead of jumping to the mouse pointer position). – JanC Aug 26 '10 at 12:11
  • I tried this on 2 computers one with Lucid & one with Maverick, 2 different mice (both USB) as well as a touchpad (internally connected as PS/2), and this is visible on both. – JanC Aug 26 '10 at 12:28
  • 1
    @KeyboardMonkey this sounds like a job for MouseMonkey!! – myusuf3 Aug 26 '10 at 13:38
  • Can you check to see if the behavior is there if you boot into an Ubuntu live CD or other distro live CD? Might help determine whether this is a config problem or a hardware issue. – frabjous Aug 26 '10 at 16:54

Do you happen to use unclutter (as I do/did)?

I see this behaviour when unclutter is running, but not when I kill it. I am not sure why it happens, as it happens "long" before unclutter hides the mouse pointer.

It also seems like there are a bunch of bug reports related to this issue (only 3 or 4 out of 17 bugs are about unrelated issues, it seems).

  • That is it. The bug is in unclutter. Killing unclutter fixes it. – Owais Lone Aug 27 '10 at 11:25
  • 1
    You can disable unclutter automatic startup in /etc/default/unclutter (or uninstall it, of course). – JanC Aug 27 '10 at 18:34
  • yeah.. i already removed it. – Owais Lone Aug 30 '10 at 7:18
  • @JanC: I had a different question. I new I had unclutter installed and running, I just didn't know why it kept running at startup, and with different options to what I had last run it with (or ever run it with for that matter). Your comment has answered that for me. :-D Thanks. – James Haigh Jul 2 '13 at 15:37
  • I think unclutter should not run by default; it should be up to each user to set in Startup Applications if they want it, and with their preferred options. The current defaults are simply asking for the kind of confusion in this question. – James Haigh Jul 2 '13 at 15:42

Can you try another mouse? I say that because I've had something like this before (way back when I was on Windows) and it was actually a dodgy connection in the mouse's cable that was causing tiny movements. It looks like your cursor doesn't move but there might tiny movements that you can't see.

Actually on that note you could fire up xev from a terminal and leave your cursor in the white box that pops up. If, once you've left the mouse alone, signals still explode out of the terminal, you've got a problem. You'll see which signals they are. If they're movement-related, it's probably a dodgy mouse.

If it's sending a full click, it could be hardware but it could also be accessibility settings kicking in. Check Preferences>Mouse>Accessibility and make sure "Dwell Click" is turned off.

  • It's not a hardware issue. The problem persists when I disconnect the mouse and use the touchpad. The problem does not show up during a live cd session either. xev also appears to be fine. It's a software problem. – Owais Lone Aug 25 '10 at 7:40

I cannot reply to other's answers yet, so here my comment to the first answer: please note that making 'unclutter' part of Ubuntu Maverick's default installation was a communication failure and not intended to happen. Indeed, the change was reverted quickly after 'unclutter' accidentally was made part of the default installation. If you have it installed still, you can remove it and should, if you want your installation to follow the official desktop.


At around 00:20 in your video, did you click the window to focus it, or did the window focus automatically on mouse hover? It seems like something is left-clicking the pointing device (mouse/touchpad) every few seconds.

  • Left-clicking would launch the menu-items, which doesn't happen. It's more like if somehow a "change focus to the widget below the cursor"-event is sent. – JanC Aug 26 '10 at 12:18
  • If it was throwing a left-click, @10s in, the dictionary would have loaded. – Oli Aug 26 '10 at 12:19
  • Although, no, as that wouldn't explain the thing I see in OOo. Maybe it's more like if the focus gets lost (and then the mouse pointer location is used to refocus)? – JanC Aug 26 '10 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.