This seems to be a recurring question, but none of the solutions I found here and there seem to work for me. So here are the facts:

  • Toshiba Satellite P855-30D
  • Nvidia 640M
  • BIOS 1.50
  • Ubuntu 13.04 64 bits
  • Always at full backlight

I've tried the 4 variants given here: http://ubuntuforums.org/showthread.php?t=2139397&p=12621502&viewfull=1#post12621502 with no luck. Some of them make /sys/class/backlight/* empty. But even when it is populated, whatever I put in /sys/class/backlight/acpi_video0/brightness is ignored.

The brightness keys are fn-F2 and fn-F3 on this model. fn-F2 opens the Power Statistics, fn-F3 crashes X. Other function keys work fine.

Edit after upgrading the BIOS to latest 6.70 :

/sys/class/backlight/ is populated

changing /sys/class/backlight/acpi_video0/brightness has no effect

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor"
/sys/class/backlight/ is empty

No param to change

/sys/class/backlight/ is populated

changing /sys/class/backlight/acpi_video0/brightness has no effect

GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
/sys/class/backlight/ is populated

changing /sys/class/backlight/acpi_video0/brightness has no effect

Opened a bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1199062 since conventional solutions are not working.

  • I assume that every time that you modified your /etc/default/grub you also ran sudo update-grub and rebooted? That's a common mistake that people forget is necessary if they do anything to the GRUB parameters.
    – gravity
    May 30, 2013 at 20:51
  • Yes I did. Another idea ?
    – Julien C.
    May 31, 2013 at 17:31

1 Answer 1


I found a solution : use nvidia's proprietary drivers. As soon as the driver is loaded, the settings scrollbar is working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .