Okay, just the other day, I was trying to install Ubuntu on an 8GB flash drive. Near the end of the installation process, the install failed. The flash drive is now entirely dysfunctional.

At first, the flash drive would mount on Windows, but not on Ubuntu. In Ubuntu, by Disk Utility, GParted, and Terminal, I was not able to format the flash drive, it only returned errors. When I took it to Windows, it will mount it, but I can't move any files because it will return an error that the flash drive is write protected. Same thing happens when I try to format it, both by the formatting tool and Command Prompt. I tried another format tool I found online after searching elsewhere for this problem, but the program crashed, and now Windows won't even mount the flash drive, saying that I need to format it.


See if there is a switch on it. If there is try moving it. If not continue reading.

I had two flash drives that this happened to. I've tried everything available, and nothing worked. Formatting with Linux, adjusting registry settings in Window, nothing. Until I came across OnBlay.

OnBelay. Download, install and use it to try and low-level format the drive. If it works, great, otherwise your USB flash drive, well... OnBlay is a windows application, since you mentioned that you're running Windows as well.

If it doesn't work, I would recommend just going out and purchasing a new USB drive.

Note: It only worked on one of my drives, and I had to buy another one. Hope it will help you.

  • suggestion:Tried software/firmware from manufacturers? – geezanansa Aug 10 '13 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.