11

After an apt-get update && apt-get upgrade my middle mouse button paste stopped working on the Xserver/12.04.2 LTS. It might have been due to a apt-get autoremove as well, which i ran just afterwards, but i don't recall the specific point when it stopped working. Basically copy-paste is gone which i've never seen before on any xserver i've used... quite a handicap.

I've re-installed xsel. If i mark text in xterm and call xsel -p i do see the marked text, so apparently selections are being copied into the primary selection buffer, only the paste key functionaltiy is gone.

Any idea on how to bind any mouse key to paste text from the selection buffer in applications (esp xterm, urxvt) ? (It does not have to be middle mouse button in particular).

6

enter image description hereIMO easiest method is to install gpointing-device-settings

sudo apt-get install gpointing-device-settings

You then 'use wheel emulation'

gpointing-device-settings looks as in image.

try this it may help you out.

  • Thanks.. works great. I used middle mouse button emulation though. So it was gnome which disabled the middle click with an update. – count0 May 30 '13 at 19:55
2

In Ubuntu 14.04 (and using xfce), this worked for me:

gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true

because gpointing-device-settings was causing segfaults for me.

  • 3
    The key was removed since 2016.04, I believe. Error message is: No such key 'middle-button-enabled' – Peer Gynt Apr 29 '17 at 12:09
  • I just used it in 14.04 LTS and it worked fine. – Volker Seibt Jun 9 '17 at 7:29
2

This is for future me mostly.

cat /etc/issue
Ubuntu 16.04.2 LTS \n \l
  1. Run gnome-tweak-tool
  2. Keyboard/mouse
  3. Middle click => ON

Gnome tweak tool on keyboard/mouse tab

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.