1

I was going to upgrade from 12.04 to 12.10 and skipped the update for libmagickcore4-extra, and some problem occurred, and the upgrade stopped. Now, whenever I try and open the Software update, I get this message:

Could not initialize the package information

An unresolvable problem occurred while initializing the package information.
Please report this bug against the 'update-manager' package and include the following error message:
'E:The package libmagickcore4-extra needs to be reinstalled, but I can't find an archive for it'

I tried finding a solution on How do I resolve unmet dependencies after adding a PPA? but with no luck.

The terminal gives the same error message.

Please Help!!

2

In Ubuntu >= 12.10 limagickcore4 was replaced by libmagickcore5. This should however be resolved with your release upgrade after you had regularly installed imagemagick Install imagemagick from the repositories.

In case you had it installed from ppa or locally you need to deactivate the ppa and manually purge this package before you can reinstall imagemagick.

It may also be that you manually had installed another package which depends on libmagickcore4. You will have to remove/upgrade this package first before you can proceed.

  • i just opened ubuntu after about 6 months ... i updated everything that i could through the software centre ... then when i went on to upgrade ubuntu from 12.04 to 12.10 .. this happened ... if the file was replaced by libmagickcore5, why is it asking me to reinstall core4 ... it doesnt make sense .... ubuntu software centre,software update dont run ... so i downloaded a package from one of the websites .. but i cant seen to get my head around the package ... – Venky May 30 '13 at 14:10
1

As Takkat mentioned, the limagickcore4 was replaced by libmagickcore5 in the official repositories for Ubuntu. You may check which versions you can install using the apt-cache command.

$ apt-cache search libmagick

You may try to find which packages depends on limagickcore4 and remove them.

$ apt-cache rdepends --installed libmagickcore4-extra

However, sometimes it is hard to determine which packages that depend on libmagickcore4 can be uninstalled or replaced. You may try aptitude to find a solution. When you run the program, it shows you multiple solutions that may imply to install, downgrade, upgrade or remove multiple packages.

$ sudo aptitude

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.