I am running QQ - default Ubuntu/Unity desktop

Installed kubuntu-desktop with 'apt-get install kubuntu-desktop' to try it out. Decided I didn't like it, so I removed it with 'apt-get remove kubuntu-desktop'.

When kubuntu-desktop installed, apt-get told me it would take over 400mb of disk space. But when I removed it, it only removed about 50mb worth of packages. Obviously, everything was not removed.

I ran deborphan which listed a long list of packages that were no longer in use, all related to Kubuntu (apparently).

I started removing the packages listed in deporphan one by one with apt-get. apt-get told me there were a lot of unused packages and I could run 'apt-get autoremove'.

So I ran 'apt-get autoremove' which deleted a great deal of stuff - about 400 mb - apparently the packages and apps that were not removed when I just ran 'apt-get remove kubuntu-desktop'.

But now, when I run the default Ubuntu/Unity desktop, things look different: fonts are bigger on all the menus, tabs and windows and backgrounds look very square and old-fashioned and on some apps the theme and color settings don't seem to be working right.

Looks like when I ran 'apt-get autoremove' it removed parts of the Gnome GUI framework that default Ubuntu/Unity uses. (Or maybe some parts of kubuntu/KDE are still in there and the GUI is defaulting to use them...?)

How can I fix this? What packages do I need to re-install or remove?

Edit: What I noticed now in particular is that the the widget frames and some of the colors look like Kubuntu. For example, the window frames are dark grey and square and don't show shadowing and highlighting the way Unity does. And in Firefox, when I added a new folder to the bookmark toolbar, the folder showed up with a Dolphin style folder icon, not what you seen normally - not similar to the icon ins Nautulis (why do look OK) . Looks it's running partially Kubunta KDE widgets and partially Gnome/Unity widgets.

  • 1
    Have you removed the .gtkrc-2.0 and .fonts.conf files? KDE does not like being ignored. ;-) May 30, 2013 at 12:30
  • I don't know what apt-get autoremove did - it did an awful lot... .gtkrc-2.0 and .fonts.conf files are simple config files, not packages, correct? I did not see them in Synaptic at all. Can I just copy them from someplace? Install them? where do they go? . As I said below, it's actually not bad the way it is now - clearer and faster in some aspects it seems - and I don't think anything is broken- but some things just look sort of OLD. Tnx.
    – Vector
    May 30, 2013 at 14:00

2 Answers 2


I reinstalled Kubuntu and used the KDE system settings applet to adjust the style, fonts, widgets, etc. This seems to have fixed most of the issues.

So I have both Kubuntu and Unity on that machine- not using Kubuntu and there are doubles of a lot of apps (also some cool KDE utilities that aren't in Unity) but Unity looks good now.


sudo apt-get install --reinstall ubuntu-desktop will re-install all the default Unity desktop packages back to your system, other than that try to check if there is any KDE configuration still left behind messing anything as suggested.

  • --reinstall ubuntu-desktop didn't seem to do anything. Didn't download anything, just reinstalled the desktop. Everything still looks the same, even after I bounced the machine. It's actually not bad - clearer and faster in some aspects it seems - and I don't think anything is broken- but some things just look sort of OLD.
    – Vector
    May 30, 2013 at 13:58
  • See edit please. Tnx.
    – Vector
    May 30, 2013 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .