TL;DR Has anyone managed to enable DVI output with the "Switchable Graphics" setting in the BIOS on a ThinkPad T430?

I am trying to get to work switchable graphics with bumblebee, in order to enable the DVI output of my docking station. So far I have managed installing bumblebee following the Ubuntu instructions, section "Advanced setups". I havent't installed the proprietary NVIDIA drivers nor the bumblebee-nvidia package.

I can turn the discrete graphics adapter on and off:

echo ON > /prop/acpi/bbswitch
echo OFF > /prop/acpi/bbswitch

I have tried to fix a different bug by adding

BusID "PCI:01:00:0"

to the Display section of /etc/bumblebee/xorg.conf.nouveau. Now, when trying

optirun -vvv glxgears

I'm getting the following output:

[ 1470.318076] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1470.318859] [DEBUG]optirun version 3.2.1 starting...
[ 1470.318875] [DEBUG]Active configuration:
[ 1470.318879] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1470.318882] [DEBUG] X display: :8
[ 1470.318885] [DEBUG] LD_LIBRARY_PATH: 
[ 1470.318889] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1470.318892] [DEBUG] Accel/display bridge: auto
[ 1470.318895] [DEBUG] VGL Compression: proxy
[ 1470.318898] [DEBUG] VGLrun extra options: 
[ 1470.318902] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 1470.318965] [DEBUG]Using auto-detected bridge virtualgl
[ 1470.443846] [INFO]Response: No - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[ 1470.443873] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[ 1470.443878] [DEBUG]Socket closed.
[ 1470.443903] [ERROR]Aborting because fallback start is disabled.
[ 1470.443908] [DEBUG]Killing all remaining processes.

There is a Troubleshooting section for this DRM error on the Wiki. It mainly focuses on getting things to work with the proprietary NVIDIA driver, and otherwise reads:

If you want to use the nouveau driver, check the syslog for more log entries.

I haven't found anything suspicious, short of the following:

[  891.570346] [drm] Cannot find any crtc or sizes - going 1024x768
[  891.640967] nouveau  [     DRM] allocated 1024x768 fb: 0x60000, bo ffff8801dd0f6c00

Searching for this particular error message wasn't helpful so far. (I have also posted the entire output of dmesg.

I haven't tried installing the NVIDIA drivers, and currently I'm reluctant to do so, because I don't want to recompile/reinstall the driver after every kernel update, and I'd like to stay open source as much as possible. Is it possible to enable switchable graphics (at least for DVI output) with the nouveau driver?

Ubuntu 13.04, ThinkPad T430.

2 Answers 2


hello here is equipment with nvidia-optimus-CUDA as example.

I stay only with kernel 3.9.0 and it is running best at moment here.

But I am using different nvidia-package - this is why I dont need to reconfigure with each new kernel up to today.

Have you tried it with NVIDIA_CUDA_SDK_1.1_Beta_Linux.run ?

I did it like described here (thoug it is closed there ) :


  • Erm... I'm not interested in CUDA, at least not yet. How does your answer fit my question?
    – krlmlr
    May 30, 2013 at 13:40

As seen in my answer to How do I set up a second display via DVI/viewport with a Lenovo T420S?, things "just work" with the NVIDIA driver, at least for switchable graphics (Optimus). If the drivers are installed from the Bumblebee PPA, in theory, kernel updates should be handled automatically. (I'm waiting for it...)

So, the initial question is a non-issue anymore, and I'm closing it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .