I am running ubuntu 10.10 Maverick Meerkat, and recently I am helping in testing out indicator-weather using the unstable buids. However there was a bug which caused my system to freeze suddenly (due to indicator-weather not ubuntu) and the only way to recover is to do a hard reset of the system. This happened a couple of times.

And when i tried to open banshee after a couple of such resets I get the following fatal error which forces me to quit banshee.

enter image description here

The screenshot is not clear enough to read the error, so I am posting it below,

   An unhandled exception was thrown: Sqlite error 11: database disk image is malformed (SQL: 
                BEGIN TRANSACTION;
                    DELETE FROM CoreSmartPlaylistEntries WHERE SmartPlaylistID IN (SELECT SmartPlaylistID FROM CoreSmartPlaylists WHERE IsTemporary = 1);
                    DELETE FROM CoreSmartPlaylists WHERE IsTemporary = 1;
                COMMIT TRANSACTION)

  at Hyena.Data.Sqlite.Connection.CheckError (Int32 errorCode, System.String sql) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.Connection.Execute (System.String sql) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in <filename unknown>:0 
Exception has been thrown by the target of an invocation.

  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in <filename unknown>:0 
  at System.Activator.CreateInstance (System.Type type) [0x00000] in <filename unknown>:0 
  at Banshee.Gui.GtkBaseClient.Startup () [0x00000] in <filename unknown>:0 
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.StartupInvocationHandler startup) [0x00000] in <filename unknown>:0 

.NET Version: 2.0.50727.1433
OS Version: Unix

Assembly Version Information:

gkeyfile-sharp (
Banshee.AudioCd (
Banshee.MiniMode (
Banshee.CoverArt (
indicate-sharp (
notify-sharp (
Banshee.SoundMenu (
Banshee.Mpris (
Migo (
Banshee.Podcasting (
Banshee.Dap (
Banshee.LibraryWatcher (
Banshee.MultimediaKeys (
Banshee.Bpm (
Banshee.YouTube (
Banshee.WebBrowser (
Banshee.Wikipedia (
pango-sharp (
Banshee.Fixup (
Banshee.Widgets (
gio-sharp (
gudev-sharp (
Banshee.Gio (
Banshee.GStreamer (
System.Configuration (
NDesk.DBus.GLib (
gconf-sharp (
Banshee.Gnome (
Banshee.NowPlaying (
Mono.Cairo (
System.Xml (
Banshee.Core (
Hyena.Data.Sqlite (
System.Core (
gdk-sharp (
Mono.Addins (
atk-sharp (
Hyena.Gui (
gtk-sharp (
Banshee.ThickClient (
Nereid (
NDesk.DBus.Proxies (
Mono.Posix (
NDesk.DBus (
glib-sharp (
Hyena (
System (
Banshee.Services (
Banshee (
mscorlib (

Platform Information: Linux 2.6.35-27-generic i686 unknown GNU/Linux

Disribution Information:



Just to make it clear, this happened only after the hard resets and not before. I used to use banshee everyday and it worked perfectly.

Can anyone help me fix this?


2 Answers 2


This problem is, unfortunately, not completely uncommon. It's often caused by a system crash or power outage while Banshee is running, but there may be other causes as well. The Banshee FAQ page has a list of instructions that work most of the time. In terminal, with the sqlite3 program installed, try this:

Change into the directory where Banshee stores the database:

cd ~/.config/banshee-1

Execute the ".dump" command on the database, which will convert all tables to text. Save this output in a file named dump. You may need to sudo apt-get install sqlite3 if you don't already have it.

sqlite3 banshee.db ".dump" > dump

Rename your current database to create a backup:

mv banshee.db banshee.db.backup

Pass the contents of your dump through the sqlite3 command, creating a new database (hopefully with the same contents as the original):

cat dump | sqlite3 banshee.db

There is ongoing work in Banshee to make database backup and recovery automatic. If you want to stay up-to-date on the progress, feel free to CC yourself to the bug report.

  • Thankx MichaelMS. I am glad to hear that there is a bug report to get this process automated thereby making banshee more reliable and ofcourse working out of the box without the user having to worry about anything...a mark of a good program :)
    – nik90
    Mar 15, 2011 at 22:28

It looks like Banshee's database has become corrupt. To make Banshee run, you should remove the corrupt database file (or repair it). The database is located at


Rename it, and Banshee can run again. But all your settings are lost. If you'd like to recover it, follow this article.

That consists of:

  1. Open a terminal window and navigate to ~/.config/banshee-1 and install sqlite3: sudo apt-get install sqlite3
  2. Backup the file banshee.db by copying it.
  3. Open the database file using sqlite3: sqlite3 banshee.db
  4. Do an integrity check by issuing the command PRAGMA integrity_check;. This reports errors, but does not correct those
  5. Try the command REINDEX;

If none of the above worked, continue reading Recovering a Corrupted Banshee Database.

  • Thnx a lot..I couldn't repair it. So I had to delete the database. And after that banshee started re-importing everything back. But thanks...
    – nik90
    Mar 13, 2011 at 15:38
  • @Nik, if you still have your corrupt database, see my post below. There are actually official instructions from the Banshee team on fixing this issue while the team works on implementing automated recovery. I'm not promising it would work, but it's worth a shot. Mar 14, 2011 at 13:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .