I have a network printer and my machine recently stopped being able to print, other machines can print fine. Besides having to use root to change its settings, when I try to change its settings I get the following error:

CUPS "client-error-not-possible".

Many forum threads suggest installing smbclient to solve the issue, but I already have it installed.

  • 3
    thx, installing smbclient worked for me! – lhlmgr Jun 24 '16 at 11:54

Installing samba, smbclient and running

sudo sed -i '/^\[global]/aclient max protocol = SMB3' /etc/samba/smb.conf

did the trick. Not sure if the last part is necessary though.

|improve this answer|||||
  • 1
    On Linux Mint 19. Just installing "samba" and "smbclient" was enough for me: I ran "sudo apt install samba" and "sudo apt install smbclient". I then ran also the printer configuration with sudo, i.e. "sudo system-config-printer", but I don't know if that (running it with sudo) was really necessary. – Mikko Östlund May 2 '19 at 13:45

My issue was having entered lpd://printer.printland.com instead of just printer.printland.com in the Host field of gnome-printer-config.

|improve this answer|||||

I was able to solve my issue by removing the printer and then readding it again using the system-config-printer wizard and searching for a new network printer.

|improve this answer|||||

On Ubuntu 19.04, installing the smbclient solves the problem. So, open a terminal and run the following command :

sudo apt-get install smbclient
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.