11

I'm having severe issues w/ package-loss and a generally bad connection w/in a WiFi-network at my uni. I'm usually encountering a package loss of ~50% and aborting connections which makes working w/ SaaS impossible.

I'm using Ubuntu 13.04 and my network-adapter is an Atheros AR9462.

Applying the nohwcrypt=1-option doesn't change anything.

Also very noticable: The connection works as intended in other networks; the problematic network uses WPA2 w/ MSCHAPv2.

Anyone can help my out here?

$ sudo lshw -class network  *-network UNCLAIMED     
       description: Ethernet controller
       product: NetLink BCM57780 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:d3500000-d350ffff
  *-network
       description: Wireless interface
       product: AR9462 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 01
       serial: e0:06:e6:76:ba:89
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.8.0-22-generic firmware=N/A ip=131.173.74.130 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:19 memory:d3400000-d347ffff memory:9fb00000-9fb0ffff
  • 2
    The nohwcrypt = 1 option that you are referring to is from this? Just to clarify, did you follow that exactly? (meaning you typed options ath9k nohwcrypt=1 in /etc/modprobe.d/ath9k.conf – sameetandpotatoes Aug 17 '13 at 20:42
  • Can you post the output of modinfo ath9k? – Radu Rădeanu Aug 17 '13 at 20:45
  • I have also heard that disabling ipv6 solves the issue, from here. If that does not work, try this Read the post that starts with: This driver compiled on the kernel you are using with no errors or warning. Install linux-headers-generic for your kernel version and build-essentials then: Please download compat-wireless-3.6.8-1 from the link below. – sameetandpotatoes Aug 17 '13 at 20:49
  • My ath9k card doesn't suffer from a hardware crypto bug, but does have deplorable signal strength. Just something worth thinking about. It's in an ASUS lappie and does a solid job of behaving as I would expect, but the signal strength I receive when compared to some other laptops/wireless rigs is a bit low...I'm just saying don't rule out signal strength and lack of an external antenna or built in antenna ring. – RobotHumans Aug 20 '13 at 22:34
  • I had this problem with an Acer Aspire V5 with AR9462. None of the suggested fixes worked. I finally got wifi working perfectly by changing a setting on my modem. I changed bandwidth from 20/40 MHz to just 20 MHz. – user222008 Dec 4 '13 at 11:45
3
+100

Looks like a bug in network manager. Bug

Run this command in the terminal:

sudo gedit /etc/NetworkManager/system-connections/essid  

Where it says essid in the command above type the name of your wireless network. A file should open then enter your user password change the line "system-ca-certs=true" to "system-ca-certs=false" save and close gedit or whatever text editor you are using, then reboot.

Then connect as you normally do using network manager.

Also some people say just removing "system-ca-certs=true" from the file worked for them but a few people reported that the file recreates itself on reboot that is why I suggest changing true to false instead of removing the line completely.

If you are not using gedit as your text editor in the command above type the name of the editor you are using in place of gedit.

2

I have an Acer V5-131 with an AR9462. It worked for some access points but cut out/reconnected on others. This is the line in /etc/modprobe.d/ath9k.conf that fixed it for me:

options ath9k nohwcrypt=1 blink=1 btcoex_enable=1

Good luck.

  • 1
    I have an Acer S5 with an Atheros AR9462 that I outfitted with Crunchbang. Creating /etc/modprobe.d/ath9k.conf with one line: options ath9k nohwcrypt=1 did it for me. – Meredith Nov 12 '13 at 8:21
0
options ath9k nohwcrypt=1 blink=1 btcoex_enable=1

instead of

options ath9k nohwcrypt=1 

in /etc/modprobe.d/ath9k.conf

Work like a charm for Acer Aspire S3-391

0

Could not get my AR9462 wireless working correctly without drops after thirty minutes with the suggestions above on an ASUS X201E that came with 12.04 on any kernel after 3.2.0-54.

Finally stumbled upon this and updated my kernel to 3.12.2-031202-generic and everything works great. If you install this and it doesn't work you can roll back to the previous kernel at boot. How to here: http://www.unixmen.com/linux-kernel-3-12-2-available-download-installation-instructions-ubuntu-linux-mint/

0

Changing my router channel to 1 fixed exactly this problem for my AR9462 wireless. None of the ath9k options had any effect.

protected by Community Jan 27 '14 at 2:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.