0

Two days before i have got this model Lenovo G580(20157) with i5 processor and nvidia 610m graphic card...

I want to install Ubuntu and Windows 7 or Windows 8 in Dual boot...

what i have done to do this:

1.Installed windows 8 with no problem and it was working completely fine

2.I restarted my laptop and inserted ubuntu 12.04 64 bit cd

3.Ubuntu installation setup started and in that it was showing that there is no operating system preinstalled on this machine.......it was showing that my complete hard drive is blank......but when i removed my ubuntu cd without installing it and restarted the computer windows 8 was working fine...

  1. I have tried with Ubuntu 12.04 332 bit and with linux mint 14 64 bit also but the same scenario occured

the problem which i am facing is because of UEFI technology which started coming in recent laptop's

Please help me ..it is a serious problem for me as........even though Wubi also do not work.....

  • 1
    You need to disable the UEFI Secure Boot in the BIOS. – Mitch May 29 '13 at 8:09
  • i have tried that also and then tried to install but all in vain – exploitprotocol May 29 '13 at 8:22
1
  1. Disable SecureBoot in your BIOS. If possible, also disable FastBoot and IntelSRT.
  2. Reduce your Windows partition via Windows tools
  3. Install Ubuntu 64bit via the "Something else" option (screenshot). For example if you have 100GB free space, you will fill it with a 2GB SWAP partition and a 98GB root partition. See this page for more info.
  4. Reboot your PC and check if you can access both Windows and Ubuntu.
  5. If needed, use Boot-Repair to make the GRUB menu boot both Ubuntu and Windows.

If you cannot disable SecureBoot at step 1, then follow those 3 steps instead of the 5 above:

  1. backup your data
  2. disable UEFI in your BIOS
  3. format your disk, then reinstall Windows (it will install in Legacy mode), then install Ubuntu.
| improve this answer | |
  • Firstly Secure boot is not there in my bios .. only UEFI enable or disable option is there ....secondly i have tried your stated method but it doesn't worked... – exploitprotocol May 29 '13 at 19:25
  • I have edited my answer above. – LovinBuntu May 30 '13 at 20:23
  • thanks for the answer ....but even this also i have tried ...no result – exploitprotocol Jun 1 '13 at 4:09
0

The symptom described (Ubuntu's installer claiming the disk is empty when in fact it's not) is usually caused by one of two things:

  • Leftover software RAID data on a disk that's no longer being used in a RAID array. This can usually be fixed by typing sudo dmraid -E -r /dev/sda (or whatever the device name is). You should be positive that you're not actually using RAID before you do this, though; sometimes even single-disk computers have RAID active.
  • A damaged partition table. Frequently my FixParts can fix this problem, but sometimes you must do something else. Precisely what else depends on the nature of the damage.

My suspicion is that you've actually installed Windows in BIOS/CSM/legacy boot mode, which has caused it to install an MBR partition table without completely wiping an older GUID Partition Table (GPT) from the disk. This will cause precisely the symptoms you report. If I'm right, FixParts will fix the problem; but then you must be careful to install Linux in BIOS mode rather than in EFI mode.

| improve this answer | |
  • no i have installed windows in uefi mode not in legacy mode – exploitprotocol Jun 1 '13 at 4:08
  • Then you probably have some other type of disk damage. If the disk is a GPT disk, try running gdisk on it and use its v option to verify the disk. That may provide some clues, or even fix the problem. Note, however, that if gdisk reports that it's converting an MBR disk to GPT format, or if it asks you whether to use GPT or MBR data structures, you're mistaken: This means you've got an MBR disk, which in turn means that Windows is installed in BIOS mode. (Knowing your boot mode is not as easy as it should be; it's easy to make a mistake about this.) – Rod Smith Jun 1 '13 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.