Okay so I recently had some problems with ubuntu software centre where if I opened it from the dashboard it would open up, but only display a white screen. Nothing happened, so if I then clicked the 'x', it would ask me if i would like to force close the non responding software centre.

To get round this I've been opening the software centre via terminal which seems to let it work fine.

But i needed it working normally and after lots of attempts I couldn't figure it out so decided to just un-install and reinstall it.

Un-install worked fine, but now for the reinstall. When i type into terminal

sudo apt-get install software-center

I get this back;

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package software-center is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'software-center' has no installation candidate

any ideas? Thanks :)

Ubuntu 12.04

  • try running sudo apt-get install software-center* (with an asterisk) and see if that gives you any ideas? – sk29910 May 28 '13 at 14:05
  • 8
    You need to run sudo apt-get update. Your apt cache seems broken, and apt cannot find the package. Running the update command should resolve it, or at least give you more information about whey it's broken. – dobey May 28 '13 at 14:07
  • 1111 Great.. :D – Saurav Kumar Jan 28 '14 at 4:38

Like @dobey said, you should give the command sudo apt-get update a whirl. You may have a problem with your apt-cache and as such, you will have problems installing things.

Run the command sudo apt-get update && sudo apt-get upgrade. This will check for any and all updates/upgrades, hopefully fixing your system.

Once this runs, try running @sebastian_k's answer, sudo apt-get install software-center*. This will get/install anything and everything that Ubuntu Software Center needs to run.

| improve this answer | |
  • 1
    Already tried the; sudo apt-get update and the software-center* has no luck :/ – KyloR May 28 '13 at 15:27
  • Oh, hmm. Dunno then...I'll keep looking though. Hope you find the answer soon, having a broken system is not fun (I've had to reinstall a few times because of it.) – RPiAwesomeness May 28 '13 at 15:29
  • Thanks for trying, but in the end ive just resorted to completely wiping my hard drive and installing ubuntu 13.04. Always nice to have a fresh start every now and then! – KyloR May 28 '13 at 16:12

You need to type

sudo apt install gnome-software

to install software center.

| improve this answer | |

Make sure you have the repository link. From: Main Menu: System > Administration > Software Sources. Make sure that the Main repository is selected.
You can get a PPA with: sudo add-apt-repository ppa:software-store-developers/daily-build or sudo add-apt-repository ppa:ubuntuone/nightlies

It's generally recommended to just download the source code

You can get it from:


Or directly from:


Or you can get it in Synaptic.

| improve this answer | |
  • 1
    I don't believe he need a ppa to install USC. – Braiam Sep 11 '13 at 1:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.