I have some strange problems with Samba server. I am using samba Version 3.5.4 on Ubuntu 10.10.

I have two Windows XP machines, one on VirtualBox on Ubuntu and another office laptop. Windows machine on VirtualBox has no issues in accessing the shared folders, but the laptop is not able to access all the shared content.

The issue faced on laptop is the following.

Shared folders on ext3 drives have no issues in accessing, but the contents shared on NTFS and FAT32 drives (mounted ones) are not accessible. When I try to open the shared folder, it asks for user name and password, but doesn't accept when I provide it. (Even if I provide admin login details).

I changed workgroup value to the domain_name in office laptop, but still the problem persists.

Here is the smdb.conf I am using:

workgroup = XXX.XXX.ORG
server string = %h server (Samba, Ubuntu)
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
guest ok = Yes

comment = Home Directories

comment = All Printers
path = /var/spool/samba
read only = No
create mask = 0700
printable = Yes
browseable = No

comment = Samba server's CD-ROM
path = /cdrom
force user = nobody
force group = nobody
locking = No 

Workgroup was defined as "HOMENET" before, changed it to domain name on the office laptop thinking it was the problem, but for no avail.


Eventually, that may be a firewall issue. If I got you right, the samba server is running on the same PC as the virtualized windows. Dependent on the network setup of VirtualBox, the virtualized windows probably is considered "local" by the samba server.

But when trying to get access from the second PC (office laptop), this PC surely is not considered local by the samba server. My advice would be to turn off the firewall on the samba server for a minute (just for testing). To my regrets, I can't tell you how to do this because I am writing my firewall rule sets by hand and have never managed the firewall by GUI applications, but it should not be a big problem.

If you are wondering: Firewalls could very well be the case that you get a login prompt, but can't access the data. Login and accessing data are different actions from the SMB protocol's point of view which may run on different ports and exchange data in both directions.

It may even be the case that the laptop's firewall is the root of the evil.

One more possibility: In the samba configuration, there is a simple access management. For example, you can determine what IP is allowed to access on a per-share basis or globally. It may be the case that you explicitely have to allow access for non-local IP addresses; I just can't remember at the moment.

I still have an additional idea, but would like you to do the tests I have mentioned above first (turn off firewalls on the laptop and the samba box, make IP ACLs in samba configuration explicitely giving access to the laptop's IP).



  • Thanks for suggestions. I will try this and comeback. I have one doubt. If Firewall was the problem, I shouldn't have been able to access shared folders on the ext3 drives. ??? – Microkernel Mar 14 '11 at 9:20

Most probably your filesystem permissions are wrong. If your disk is mounted with wrong user (and with 700 or similar permissions), samba is not going to show those.

You can start debugging the issues with samba logs: /var/log/samba/.

Changing the workgroup do not matter, whole point of workgroup is just to separate what machines are shown in the listings. It's not access control.

  • Thanks Olli, The filesystems are mounted under administrator login itself. The strange thing is, there is no issue in accessing shared folders from Win-XP on Virtual Box but not from Win-XP on laptop. ! – Microkernel Mar 13 '11 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.